<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#">
<head>
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0" />

    <meta name="pwaforwp" content="wordpress-plugin"/>
                      <meta name="theme-color" content="#D5E0EB">
<link rel="manifest" href="/pwa-manifest.json"/>
<link rel="apple-touch-icon" sizes="192x192" href="https://fosspost.org/wp-content/uploads/2018/02/logo.png">
<link rel="apple-touch-icon" sizes="512x512" href="https://fosspost.org/wp-content/uploads/2018/02/logo.png">

<!-- Search Engine Optimization by Rank Math - https://s.rankmath.com/home -->
<title>The Status Of Fractional Scaling (HiDPI) Between Windows &amp; Linux</title>
<meta name="description" content="There&#039;s a special type of displays commonly called &quot;HiDPI&quot;, which means that the number of pixels in the screen is doubled (vertically and horizontally), m"/>
<meta name="robots" content="follow,index"/>
<link rel="canonical" href="https://fosspost.org/analytics/fractional-scaling-between-windows-linux" />
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="The Status Of Fractional Scaling (HiDPI) Between Windows &amp; Linux">
<meta property="og:description" content="There&#039;s a special type of displays commonly called &quot;HiDPI&quot;, which means that the number of pixels in the screen is doubled (vertically and horizontally), m">
<meta property="og:url" content="https://fosspost.org/analytics/fractional-scaling-between-windows-linux">
<meta property="og:site_name" content="FOSS Post">
<meta property="article:publisher" content="http://www.facebook.com/fosspost">
<meta property="article:section" content="Analytics">
<meta property="article:published_time" content="2019-07-21T18:40:04+00:00">
<meta property="article:modified_time" content="2019-07-21T18:44:58+00:00">
<meta property="og:updated_time" content="2019-07-21T18:44:58+00:00">
<meta property="og:image" content="https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_21-22.png">
<meta property="og:image:secure_url" content="https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_21-22.png">
<meta property="og:image:width" content="1920">
<meta property="og:image:height" content="964">
<meta property="og:image:alt" content="fractional scaling">
<meta property="og:image:type" content="image/png">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="The Status Of Fractional Scaling (HiDPI) Between Windows &amp; Linux">
<meta name="twitter:description" content="There&#039;s a special type of displays commonly called &quot;HiDPI&quot;, which means that the number of pixels in the screen is doubled (vertically and horizontally), m">
<meta name="twitter:site" content="@fosspost">
<meta name="twitter:creator" content="@realmhsabbagh">
<meta name="twitter:image" content="https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_21-22.png">
<script type="application/ld+json">[{"@context":"https:\/\/schema.org","@type":"Article","headline":"The Status of Fractional Scaling (HiDPI) Between Windows & Linux","description":"There's a special type of displays commonly called \"HiDPI\", which means that the number of pixels in the screen is doubled (vertically and horizontally), m","datePublished":"2019-07-21T18:40:04+00:00","dateModified":"2019-07-21T18:44:58+00:00","publisher":{"@type":"Organization","name":"FOSS Post","logo":{"@type":"ImageObject","url":"https:\/\/fosspost.org\/wp-content\/uploads\/2016\/12\/logo.png"}},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/fosspost.org\/analytics\/fractional-scaling-between-windows-linux"},"author":{"@type":"Person","name":"M.Hanny Sabbagh"},"image":{"@type":"ImageObject","url":"https:\/\/i1.wp.com\/fosspost.org\/wp-content\/uploads\/2019\/07\/2019-07-21_21-22.png?fit=1920%2C964&ssl=1","width":1920,"height":964}},{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/fosspost.org","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/fosspost.org\/analytics","name":"Analytics"}},{"@type":"ListItem","position":3,"item":{"@id":"https:\/\/fosspost.org\/analytics\/fractional-scaling-between-windows-linux","name":"The Status of Fractional Scaling (HiDPI) Between Windows &#038; Linux"}}]}]</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel="amphtml" href="https://fosspost.org/analytics/fractional-scaling-between-windows-linux/?amp" /><meta name="generator" content="AMP for WP 0.9.98"/><link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="FOSS Post &raquo; Feed" href="https://fosspost.org/feed" />
<link rel="alternate" type="application/rss+xml" title="FOSS Post &raquo; Comments Feed" href="https://fosspost.org/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="FOSS Post &raquo; The Status of Fractional Scaling (HiDPI) Between Windows &#038; Linux Comments Feed" href="https://fosspost.org/analytics/fractional-scaling-between-windows-linux/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/fosspost.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='bdaia_shorty-style-css'  href='https://fosspost.org/wp-content/plugins/bdaia-shortcodes/assets/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='mci-footnotes-css-public-css'  href='https://fosspost.org/wp-content/plugins/footnotes/class/../css/public.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.2.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://c0.wp.com/c/5.2.2/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='bdaia_shorty_stylesheet-css'  href='https://fosspost.org/wp-content/plugins/bdaia-shortcodes/assets/shortcodes.css' type='text/css' media='all' />
<link rel='stylesheet' id='cresta-social-crestafont-css'  href='https://fosspost.org/wp-content/plugins/cresta-social-share-counter-pro/css/csscfont.css' type='text/css' media='all' />
<link rel='stylesheet' id='cresta-social-wp-style-css'  href='https://fosspost.org/wp-content/plugins/cresta-social-share-counter-pro/css/cresta-wp-css.css' type='text/css' media='all' />
<link rel='stylesheet' id='cresta-social-googlefonts-css'  href='//fonts.googleapis.com/css?family=Noto+Sans:400,700' type='text/css' media='all' />
<link rel='stylesheet' id='cresta-social-hover-css'  href='https://fosspost.org/wp-content/plugins/cresta-social-share-counter-pro/css/cresta-hover.css' type='text/css' media='all' />
<link rel='stylesheet' id='cresta-social-animate-css'  href='https://fosspost.org/wp-content/plugins/cresta-social-share-counter-pro/css/animate.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='pwaforwp-style-css'  href='https://fosspost.org/wp-content/plugins/pwa-for-wp/assets/css/pwaforwp-main.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://c0.wp.com/c/5.2.2/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='achored-header-css'  href='https://fosspost.org/wp-content/plugins/wp-anchor-header/css/achored-header.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://fosspost.org/wp-content/plugins/wp-polls/polls-css.css' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background: #e8127a;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='ez-icomoon-css'  href='https://fosspost.org/wp-content/plugins/easy-table-of-contents/vendor/icomoon/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='ez-toc-css'  href='https://fosspost.org/wp-content/plugins/easy-table-of-contents/assets/css/screen.min.css' type='text/css' media='all' />
<style id='ez-toc-inline-css' type='text/css'>
div#ez-toc-container p.ez-toc-title {font-size: 120%;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}
</style>
<link rel='stylesheet' id='spu-public-css-css'  href='https://fosspost.org/wp-content/plugins/popups/public/assets/css/public.css' type='text/css' media='all' />
<link rel='stylesheet' id='Merriweather-css'  href='https://fonts.googleapis.com/css?family=Merriweather%3A300%2C300italic%2Cregular%2Citalic%2C700%2C700italic%2C900%2C900italic' type='text/css' media='all' />
<link rel='stylesheet' id='woohoo-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C300%2C700%7CLato%3A400%2C300%2C700%2C900%7CWork+Sans%3A400%2C300%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C600%2C700%2C800%7CPlayfair+Display%3A400%2C700%2C900%2C400italic%7CRaleway%3A400%2C300%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A400%2C300%2C100%2C700%7CMontserrat%3A400%2C700&#038;subset=latin%2Cgreek%2Cgreek-ext%2Cvietnamese%2Ccyrillic-ext%2Clatin-ext%2Ccyrillic' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://fosspost.org/wp-content/plugins/tablepress/css/default.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='enlighter-local-css'  href='https://fosspost.org/wp-content/plugins/enlighter/resources/EnlighterJS.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='woohoo-default-css'  href='https://fosspost.org/wp-content/themes/woohoo/css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='wooohoo-ilightbox-skin-css'  href='https://fosspost.org/wp-content/themes/woohoo/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='wooohoo-ilightbox-skin-black-css'  href='https://fosspost.org/wp-content/themes/woohoo/css/ilightbox/metro-black-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/7.5.3/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var bd_w_blocks = {"bdaia_w_ajax_url":"https:\/\/fosspost.org\/wp-admin\/admin-ajax.php","bdaia_w_ajax_nonce":"cb7465e64d"};
var bd_blocks = {"bdaia_ajax_url":"https:\/\/fosspost.org\/wp-admin\/admin-ajax.php","bdaia_ajaxnonce":"cb7465e64d"};
var bd_script = {"post_id":"4617","ajaxurl":"https:\/\/fosspost.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/footnotes/class/../js/jquery.tools.min.js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/bdaia-shortcodes/assets/js/scripts.js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/bdaia-shortcodes/assets/js/shorty-min.js'></script>
<link rel='https://api.w.org/' href='https://fosspost.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://fosspost.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://fosspost.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.2" />
<link rel='shortlink' href='https://wp.me/p8eqx7-1ct' />
<link rel="alternate" type="application/json+oembed" href="https://fosspost.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffosspost.org%2Fanalytics%2Ffractional-scaling-between-windows-linux" />
<link rel="alternate" type="text/xml+oembed" href="https://fosspost.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffosspost.org%2Fanalytics%2Ffractional-scaling-between-windows-linux&#038;format=xml" />
<style type='text/css'>.cresta-share-icon .sbutton, .cresta-share-icon .sbutton-total {text-shadow: 1px 1px 0px rgba(0, 0, 0, .4);}
			@media (max-width : 640px) {
				#crestashareicon {
					display:none !important;
				}
			}
				#crestashareicon {z-index:99; position: absolute; visibility: hidden; opacity: 0; -webkit-transition: opacity .3s ease-in-out, visibility .3s ease-in-out; -moz-transition: opacity .3s ease-in-out, visibility .3s ease-in-out; -ms-transition: opacity .3s ease-in-out, visibility .3s ease-in-out; -o-transition: opacity .3s ease-in-out, visibility .3s ease-in-out; transition: opacity .3s ease-in-out, visibility .3s ease-in-out;}
				.crestaFixed {top: 200px !important;}
			
		.cresta-share-icon .cresta-the-count, #crestashareicon .sbutton a[data-name]:hover:before {color:#ffffff!important;}
		
		.cresta-share-icon .cresta-the-total-count, .cresta-share-icon .cresta-the-total-text {color:#000000!important;}
		#crestashareicon .sbutton {clear:both;display:none;}
		#crestashareicon .sbutton {float:right;} #crestashareicon .sbutton a[data-name]:hover:before {left: inherit; right:0;}.cresta-share-icon.fourth_style .cresta-the-count {left: -11px;}
				.cresta-share-icon i.c-icon-cresta-facebook {background: #0b2228;}
				.cresta-share-icon i.c-icon-cresta-facebook:hover {border: 2px solid #0b2228!important; color: #0b2228; }
				
				.cresta-share-icon i.c-icon-cresta-twitter {background: #0b2228;}
				.cresta-share-icon i.c-icon-cresta-twitter:hover {border: 2px solid #0b2228!important; color: #0b2228; }
				
				.cresta-share-icon i.c-icon-cresta-linkedin {background: #0b2228;}
				.cresta-share-icon i.c-icon-cresta-linkedin:hover {border: 2px solid #0b2228!important; color: #0b2228; }
				
				.cresta-share-icon i.c-icon-cresta-reddit {background: #0b2228;}
				.cresta-share-icon i.c-icon-cresta-reddit:hover {border: 2px solid #0b2228!important; color: #0b2228; }
				
				.cresta-share-icon i.c-icon-cresta-whatsapp {background: #0b2228;}
				.cresta-share-icon i.c-icon-cresta-whatsapp:hover {border: 2px solid #0b2228!important; color: #0b2228; }
				
				.cresta-share-icon i.c-icon-cresta-telegram {background: #0b2228;}
				.cresta-share-icon i.c-icon-cresta-telegram:hover {border: 2px solid #0b2228!important; color: #0b2228; }
				
				.cresta-share-icon i.c-icon-cresta-mail {background: #0b2228;}
				.cresta-share-icon i.c-icon-cresta-mail:hover {border: 2px solid #0b2228!important; color: #0b2228; }
				</style>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="shortcut icon" href="https://fosspost.org/wp-content/uploads/2018/02/logo.png" type="image/x-icon" /><link rel="apple-touch-icon-precomposed" href="https://fosspost.org/wp-content/uploads/2018/02/logo.png" /><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://fosspost.org/wp-content/uploads/2018/02/logo.png" /><link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://fosspost.org/wp-content/uploads/2018/02/logo.png" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://fosspost.org/wp-content/uploads/2018/02/logo.png" /><meta name="yandex-verification" content="5127a9786366e34b" />
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-7543508590810245",
          enable_page_level_ads: true
     });
</script><script type="text/javascript">
/* <![CDATA[ */
var userRating = {"ajaxurl":"https://fosspost.org/wp-admin/admin-ajax.php" , "your_rating":"" , "nonce":"cb7465e64d"};
var userLike = {"ajaxurl":"https://fosspost.org/wp-admin/admin-ajax.php" , "nonce":"cb7465e64d"};
/* ]]> */
var bdaia_theme_uri = 'https://fosspost.org/wp-content/themes/woohoo';
</script>
<style type="text/css">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</style><!-- All in one Favicon 4.7 --><link rel="icon" href="https://fosspost.org/wp-content/uploads/2018/02/logo.png" type="image/png"/>
      <meta name="onesignal" content="wordpress-plugin"/>
          <link rel="manifest"
            href="https://fosspost.org/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="/>
          <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>    <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://fosspost.org");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '75d5390c-4f7d-42df-b695-ed902de517a2';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://fosspost.org/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['persistNotification'] = false;
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['siteName'] = 'https://fosspost.org';
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

<script src="https://fosspost.org/wp-content/plugins/pwa-for-wp/assets/vendor/js/firebase-app.min.js"></script><script src="https://fosspost.org/wp-content/plugins/pwa-for-wp/assets/vendor/js/firebase-messaging.min.js"></script><link rel="manifest" href="https://fosspost.org/pwa-push-notification-manifest.json">
<!-- BEGIN ExactMetrics v5.3.8 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-80729374-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END ExactMetrics Universal Analytics -->
			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://fosspost.org/?custom-css=6519ae5aeb" />
		<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
		<style type="text/css" media="screen">
            .footnote_tooltip { display: none; padding: 12px; font-size: 13px; color: #494949; background-color: #f7f7f7; border-width: 1px; border-style: solid; border-color: #eeeeee; border-radius: 3px; -webkit-box-shadow: 2px 2px 11px #666666; -moz-box-shadow: 2px 2px 11px #666666; box-shadow: 2px 2px 11px #666666;}        </style>
		</head>
<body class="post-template-default single single-post postid-4617 single-format-standard wp-embed-responsive " itemscope=itemscope itemtype="https://schema.org/WebPage">

<div class="page-outer bdaia-header-default bdaia-logo-center  sticky-nav-on  bdaia-post-template-style7  bdaia-sidebar-none ">
	<div class="bg-cover"></div>
			<aside id="bd-MobileSiderbar">

							<div class="search-mobile">
					<form role="search" method="get" class="search-form" action="https://fosspost.org/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>				</div>
			
			<div id="mobile-menu"></div>

							<div class="widget-social-links bdaia-social-io-colored">
					<div class="sl-widget-inner">
						<div class="bdaia-social-io bdaia-social-io-size-35">
<a class=" bdaia-io-url-facebook" title="Facebook" href="https://facebook.com/fosspost" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class=" bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/fosspost" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class=" bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/channel/UC-LJRjAuZz9lVICSseyvE2A" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class=" bdaia-io-url-rss" title="Rss" href="https://fosspost.org/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div>					</div>
				</div>
			
		</aside>
	
	<div id="page">
		<div class="inner-wrapper">
			<div id="warp" class="clearfix  bdaia-sidebar-none ">
				
<div class="header-wrapper" style ="border-top-color: #e6e6e6">

			<div class="bdayh-click-open">
			<div class="bd-ClickOpen bd-ClickAOpen">
				<span></span>
			</div>
		</div>
	
	<style type="text/css">.bdaia-header-default .topbar ul.webticker li span, .bdaia-header-default .topbar, .bdaia-header-default .topbar a, .bdaia-header-default .topbar .top-nav > li > a{color: #333333;} .bdaia-header-default .topbar .top-nav > li.menu-item-has-children:after{border-top-color: #333333;}.bdaia-header-default .topbar a:hover,.bdaia-header-default .topbar .top-nav > li > a:hover{color: #4d4d4d;}</style>
	<div class="cfix"></div>
	<div class="topbar"  style="background: #ffffff">
		<div class="bd-container">

			
			<div class="top-left-area">
				<span class="bdaia-current-time"> July 22, 2019</span>
							</div>

			
			<div class="top-right-area">
				<div class="bdaia-social-io bdaia-social-io-size-32">
<a class=" bdaia-io-url-facebook" title="Facebook" href="https://facebook.com/fosspost" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class=" bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/fosspost" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class=" bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/channel/UC-LJRjAuZz9lVICSseyvE2A" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class=" bdaia-io-url-rss" title="Rss" href="https://fosspost.org/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div>			</div>
		</div>
	</div>
	<div class="cfix"></div>

	
	
			<header class="header-container">
			<div class="bd-container">
				
    <div class="logo site--logo">
		<h2 class="site-title">					            <a href="https://fosspost.org/" rel="home" title="FOSS Post">
                <img src="https://fosspost.org/wp-content/uploads/2017/08/logo-1-1.png" alt="FOSS Post" />
            </a>
		            <script>
                jQuery(document).ready( function($)
                {
                    var retina = window.devicePixelRatio > 1 ? true : false;

                    if ( retina )
                    {
                        jQuery( '.site--logo img' ).attr( 'src', 'https://fosspost.org/wp-content/uploads/2017/08/logo-1-1.png' );
                        jQuery( '.site--logo img' ).attr( 'width', '' );
                    }
                } );
            </script>
						</h2>    </div><!-- End Logo -->
				
			</div>
		</header>
	
	
<div class="cfix"></div>
<nav id="navigation" class="dropdown-light mainnav-dark center-item-menu ">
	<div class="navigation-wrapper">
		<div class="bd-container">
			<div class="primary-menu">
															<a class="nav-logo" title="FOSS Post" href="https://fosspost.org/">
							<img src="https://fosspost.org/wp-content/uploads/2019/06/logo-2.png" width="195" height="48" alt="FOSS Post" />
						</a>
																	<ul id="menu-primary">
					<li id="menu-item-2083" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item " ><a href="https://fosspost.org/education"> <i class="fa fa fa-book"></i> <span class="menu-label" style="" >Education</span></a>

<div class="mega-menu-content">
</div><li id="menu-item-2546" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent bd_depth- bd_menu_item " ><a href="https://fosspost.org/analytics"> <i class="fa fa fa-database"></i> <span class="menu-label" style="" >Analytics</span></a>

<div class="mega-menu-content">
</div><li id="menu-item-2087" class=" menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-parent-item menu-item--parent bd_depth- bd_menu_item " ><a href="https://fosspost.org/reviews"> <i class="fa fa fa-star-half-o"></i> <span class="menu-label" style="" >Reviews</span></a>

<ul class="bd_none sub-menu">
<li id="menu-item-2088" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth-  " ><a href="https://fosspost.org/reviews/distributions">  <span class="menu-label" style="" >Distributions Reviews</span></a>
<li id="menu-item-2089" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth-  " ><a href="https://fosspost.org/reviews/programs">  <span class="menu-label" style="" >Programs Reviews</span></a>
</ul>  

<div class="mega-menu-content">
</div><li id="menu-item-2090" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item " ><a href="https://fosspost.org/tutorials"> <i class="fa fa fa-cogs"></i> <span class="menu-label" style="" >Tutorials</span></a>

<div class="mega-menu-content">
</div><li id="menu-item-4159" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item " ><a href="https://fosspost.org/lists"> <i class="fa fa fa-bars"></i> <span class="menu-label" style="" >Lists</span></a>

<div class="mega-menu-content">
</div><li id="menu-item-4158" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item " ><a href="https://fosspost.org/interviews"> <i class="fa fa fa-users"></i> <span class="menu-label" style="" >Interviews</span></a>

<div class="mega-menu-content">
</div><li id="menu-item-2086" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item " ><a href="https://fosspost.org/opinions"> <i class="fa fa fa-linux"></i> <span class="menu-label" style="" >Opinions</span></a>

<div class="mega-menu-content">
</div>				</ul>
			</div>

            <div class="nav-right-area">
			
							<div class="bdaia-nav-search">
					<span class="bdaia-ns-btn bdaia-io bdaia-io-search"></span>
					<div class="bdaia-ns-wrap">
						<div class="bdaia-ns-content">
							<div class="bdaia-ns-inner">
								<form method="get" id="searchform" action="https://fosspost.org/">
									<input type="text" class="bbd-search-field search-live" id="s" name="s" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
									<button type="submit" class="bbd-search-btn"><span class="bdaia-io bdaia-io-search"></span></button>
								</form>
							</div>
						</div>
					</div>
				</div>
			
			
			
			
            </div>

			
			<div class="cfix"></div>
		</div>
	</div>
</nav>
<div class="cfix"></div>

</div>



									<div class="bdaia-post-style7-head">
				<a class="bdaia-featured-img-cover"  style="background-image:url(https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_21-22.png?fit=1920%2C964&ssl=1);" ></a>
				<div class="bd-container">
					<header class="bdaia-post-header">
													<div class="bdaia-category">
								<a class="bd-cat-link bd-cat-221" href="https://fosspost.org/analytics">Analytics</a>
							</div>
							<!-- END category. -->
												<div class="bdaia-post-title">
							<h1 class="post-title entry-title"><span>The Status of Fractional Scaling (HiDPI) Between Windows &#038; Linux</span></h1>
						</div>
						<!-- END Post Title. -->
						
<div class="bdaia-meta-info">

			<div class="bdaia-post-author-name">
			By            <a href="https://fosspost.org/author/mhsabbagh" title="">M.Hanny Sabbagh </a>

							<a href="https://twitter.com/realmhsabbagh" target="_blank">
					<span class="bdaia-io bdaia-io-twitter"></span>
				</a>
					</div>
	
			<div class="bdaia-post-date"><span class='bdaia-io bdaia-io-calendar'></span>Posted on&nbsp;<span class="bdayh-date">July 21, 2019</span></div>
	
			<div class="bdaia-post-time-read"><span class='bdaia-io bdaia-io-clock'></span>7&nbsp;min read</div>
	
			<div class="bdaia-post-comment"><span class='bdaia-io bdaia-io-bubbles4'></span><a href="https://fosspost.org/analytics/fractional-scaling-between-windows-linux#comments">1</a></div>
	
	
	
</div>
<!-- END Meta Info. -->						<div class="bdaia-post-read-down">
							<a href="#">
								<span class="bdaia-io bdaia-io-angle-double-down"></span>
							</a>
						</div>
					</header>
				</div>
			</div>
				
                

								
                
                
																				<div class="bdMain">
	<div class="bd-container bdaia-post-template">

		<div class="bd-main bdaia-site-content" id="bdaia-primary">

			<div id="content" role="main">

				
					<article id="post-4617" class="hentry post-4617 post type-post status-publish format-standard has-post-thumbnail category-analytics"  itemscope itemtype="https://schema.org/Article">

						
						<div class="bdaia-post-content">
							
							

							
							<div id="ez-toc-container" class="counter-hierarchy counter-decimal ez-toc-light-blue">
<div class="ez-toc-title-container">
<p class="ez-toc-title">Table of Contents</p>
<span class="ez-toc-title-toggle"><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div>
<nav><ul class="ez-toc-list"><li><a href="#Fractional_Scaling_on_Linux" title="Fractional Scaling on Linux">Fractional Scaling on Linux</a><ul><li><a href="#GNOME" title="GNOME">GNOME</a></li><li><a href="#KDE" title="KDE">KDE</a></li><li><a href="#Other_Desktops" title="Other Desktops">Other Desktops</a></li></ul></li><li><a href="#Fractional_Scaling_HiDPI_Support_on_Windows_10" title="Fractional Scaling (HiDPI) Support on Windows 10">Fractional Scaling (HiDPI) Support on Windows 10</a></li><li><a href="#Conclusion" title="Conclusion">Conclusion</a></li></ul></nav></div>
<div class="truem5d35433c32546" ><center>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- fosspost_leaderboard_desktop -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-7543508590810245"
     data-ad-slot="5128096301"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center></div><style type="text/css">
@media screen and (min-width: 1201px) {
.truem5d35433c32546 {
display: block;
}
}
@media screen and (min-width: 993px) and (max-width: 1200px) {
.truem5d35433c32546 {
display: block;
}
}
@media screen and (min-width: 769px) and (max-width: 992px) {
.truem5d35433c32546 {
display: block;
}
}
@media screen and (min-width: 768px) and (max-width: 768px) {
.truem5d35433c32546 {
display: none;
}
}
@media screen and (max-width: 767px) {
.truem5d35433c32546 {
display: none;
}
}
</style>
<div class="yckgr5d35433c32387" ><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- fosspost_top_mobile -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-7543508590810245"
     data-ad-slot="3793342647"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><style type="text/css">
@media screen and (min-width: 1201px) {
.yckgr5d35433c32387 {
display: none;
}
}
@media screen and (min-width: 993px) and (max-width: 1200px) {
.yckgr5d35433c32387 {
display: none;
}
}
@media screen and (min-width: 769px) and (max-width: 992px) {
.yckgr5d35433c32387 {
display: none;
}
}
@media screen and (min-width: 768px) and (max-width: 768px) {
.yckgr5d35433c32387 {
display: block;
}
}
@media screen and (max-width: 767px) {
.yckgr5d35433c32387 {
display: block;
}
}
</style>
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><div class="crestaStickButtons"></div><p>There&rsquo;s a special type of displays commonly called &ldquo;<a href="https://www.eizoglobal.com/library/basics/pixel_density_4k/" target="_blank" rel="noopener">HiDPI</a>&ldquo;, which means that the number of pixels in the screen is doubled (vertically and horizontally), making everything drawn on the screen look sharper and better. One of the most common examples of HiDPI are Apple&rsquo;s Retina displays, which do come with their desktops and laptops.</p>
<p>However, one issue with HiDPI is that the default screen resolutions are too small to be displayed on them, so we need what&rsquo;s called as &ldquo;scaling&rdquo;; Which is simply also doubling the drawn pixels from the OS side so that they can match that of the display. Otherwise, displaying a 400&times;400 program window on a 3840&times;2160 display will give a very horrible user experience, so the OS will need to scale that window (and everything) by a factor of 2x, to make it 800&times;800, which would make it better.</p>
<p>Fractional scaling is the process of doing the previous work, but by using fractional scaling numbers (E.g 1.25, 1.4, 1.75.. etc), so that they can be customized better according to the user&rsquo;s setup and needs.</p>
<p>Now where&rsquo;s the issue, you may ask? Windows operating system has been supporting such kind of displays natively for a very long time, but Linux distributions do lack a lot of things in this field. There are many drawbacks, issues and other things to consider. This article will take you in a tour about that.</p>
<h2 id="fractional-scaling-on-linux"><span class="ez-toc-section" id="Fractional_Scaling_on_Linux">Fractional Scaling on Linux<a class="anchorlink dashicons-before" href="#fractional-scaling-on-linux"></a></span></h2>
<h3 id="gnome"><span class="ez-toc-section" id="GNOME">GNOME<a class="anchorlink dashicons-before" href="#gnome"></a></span></h3>
<p><img class="aligncenter size-large wp-image-4623" src="https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-20.png?resize=850%2C478&#038;ssl=1" alt="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 25 fractional scaling,linux" width="850" height="478" srcset="https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-20.png?resize=1024%2C576&amp;ssl=1 1024w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-20.png?resize=150%2C84&amp;ssl=1 150w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-20.png?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-20.png?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-20.png?resize=850%2C478&amp;ssl=1 850w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-20.png?w=1700&amp;ssl=1 1700w" sizes="(max-width: 850px) 100vw, 850px" title="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 26 fractional scaling,linux" data-recalc-dims="1"></p>
<p>Normal scaling in GNOME has been there for a lot of time, I don&rsquo;t even remember when it landed; You could easily switch into a 2x or 3x scaling any time you want. But the issue was that it doesn&rsquo;t support <strong>fractional</strong> scaling (E.g 125%), so you would end up in a lot of cases in either too large or too small screen resolutions.</p>
<p>In GNOME 3.32, the developers have added an &ldquo;experimental&rdquo; support for fractional scaling. Sadly, there&rsquo;s no option to enable that one in the control center, so you&rsquo;ll have to apply the following command in the terminal to enable it:</p>
<pre>gsettings set org.gnome.mutter experimental-features "['x11-randr-fractional-scaling']"</pre>
<p>After that, if you head to the GNOME Control Center, you&rsquo;ll be able to see both the 125% and 175% options now:</p>
<p><img class="aligncenter size-large wp-image-4622" src="https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-21.png?resize=850%2C711&#038;ssl=1" alt="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 27 fractional scaling,linux" width="850" height="711" srcset="https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-21.png?resize=1024%2C856&amp;ssl=1 1024w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-21.png?resize=150%2C125&amp;ssl=1 150w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-21.png?resize=300%2C251&amp;ssl=1 300w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-21.png?resize=768%2C642&amp;ssl=1 768w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-21.png?resize=850%2C711&amp;ssl=1 850w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-21.png?w=1082&amp;ssl=1 1082w" sizes="(max-width: 850px) 100vw, 850px" title="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 28 fractional scaling,linux" data-recalc-dims="1"></p>
<p>Everything looks nice so far. However, from my experiments, this experimental scaling is very buggy on GNOME.</p>
<p>The following video demonstrates how I no longer can launch Flameshot to take screenshots of my desktop. GNOME Screenshots tool does work, but I depend on Flameshot a lot in my workflow, and I can&rsquo;t offer to miss that:</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class="youtube-player" type="text/html" width="850" height="479" src="https://www.youtube.com/embed/k1q1t7od9OQ?version=3&amp;rel=1&amp;fs=1&amp;autohide=2&amp;showsearch=0&amp;showinfo=1&amp;iv_load_policy=1&amp;wmode=transparent" allowfullscreen="true" style="border:0;"></iframe></span></p>
<p>Some applications like Telegram and Steam do not scale good (Telegram does have an option in its settings to scale it up, but it doesn&rsquo;t get scaled by the DE instantly), I don&rsquo;t know if some workarounds exist for Steam or not:</p>
<p><img class="aligncenter size-large wp-image-4624" src="https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/Screenshot-from-2019-07-21-14-35-12.png?resize=850%2C478&#038;ssl=1" alt="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 29 fractional scaling,linux" width="850" height="478" srcset="https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/Screenshot-from-2019-07-21-14-35-12.png?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/Screenshot-from-2019-07-21-14-35-12.png?resize=150%2C84&amp;ssl=1 150w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/Screenshot-from-2019-07-21-14-35-12.png?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/Screenshot-from-2019-07-21-14-35-12.png?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/Screenshot-from-2019-07-21-14-35-12.png?resize=850%2C478&amp;ssl=1 850w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/Screenshot-from-2019-07-21-14-35-12.png?w=1700&amp;ssl=1 1700w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/Screenshot-from-2019-07-21-14-35-12.png?w=2550&amp;ssl=1 2550w" sizes="(max-width: 850px) 100vw, 850px" title="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 30 fractional scaling,linux" data-recalc-dims="1"></p>
<p>Also, here&rsquo;s a video demonstrating how changing the levels of brightness or volume while playing games can give an unacceptable experience (Notice how the screen lags and goes back and forth):</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class="youtube-player" type="text/html" width="850" height="479" src="https://www.youtube.com/embed/TYIj_2WDwDs?version=3&amp;rel=1&amp;fs=1&amp;autohide=2&amp;showsearch=0&amp;showinfo=1&amp;iv_load_policy=1&amp;wmode=transparent" allowfullscreen="true" style="border:0;"></iframe></span></p>
<p>Aside from the issues mentioned, fractional scaling on GNOME works good. All the native GTK apps on my desktop scaled with no problem (Nautilus, Terminal, Gedit.. Everything).</p>
<p>In addition to fractional scaling, GNOME supports fonts scaling, which allows you to control the fonts size scale only, and you can set it for whatever value you like. From my experience, I had no issues with it:</p>
<p><img class="aligncenter size-large wp-image-4625" src="https://i0.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_20-30.png?resize=850%2C600&#038;ssl=1" alt="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 31 fractional scaling,linux" width="850" height="600" srcset="https://i0.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_20-30.png?resize=1024%2C723&amp;ssl=1 1024w, https://i0.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_20-30.png?resize=150%2C106&amp;ssl=1 150w, https://i0.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_20-30.png?resize=300%2C212&amp;ssl=1 300w, https://i0.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_20-30.png?resize=768%2C542&amp;ssl=1 768w, https://i0.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_20-30.png?resize=104%2C74&amp;ssl=1 104w, https://i0.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_20-30.png?resize=850%2C600&amp;ssl=1 850w, https://i0.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_20-30.png?w=1054&amp;ssl=1 1054w" sizes="(max-width: 850px) 100vw, 850px" title="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 32 fractional scaling,linux" data-recalc-dims="1"></p>
<h3 id="kde"><span class="ez-toc-section" id="KDE">KDE<a class="anchorlink dashicons-before" href="#kde"></a></span></h3>
<p><img class="aligncenter size-large wp-image-4628" src="https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-41.png?resize=850%2C478&#038;ssl=1" alt="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 33 fractional scaling,linux" width="850" height="478" srcset="https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-41.png?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-41.png?resize=150%2C84&amp;ssl=1 150w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-41.png?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-41.png?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-41.png?resize=850%2C478&amp;ssl=1 850w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-41.png?w=1700&amp;ssl=1 1700w" sizes="(max-width: 850px) 100vw, 850px" title="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 34 fractional scaling,linux" data-recalc-dims="1"></p>
<p>I think that KDE has the best support for fractional scaling on Linux. While nothing is applied automatically out-of-the-box, fractional scaling support in KDE is stabilized. So you can simply open the KDE Settings and scale your display however you like:</p><div class="wsout5d35433c322bd" ><center>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block; text-align:center;"
     data-ad-layout="in-article"
     data-ad-format="fluid"
     data-ad-client="ca-pub-7543508590810245"
     data-ad-slot="8833916334"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center></div><style type="text/css">
@media screen and (min-width: 1201px) {
.wsout5d35433c322bd {
display: block;
}
}
@media screen and (min-width: 993px) and (max-width: 1200px) {
.wsout5d35433c322bd {
display: block;
}
}
@media screen and (min-width: 769px) and (max-width: 992px) {
.wsout5d35433c322bd {
display: block;
}
}
@media screen and (min-width: 768px) and (max-width: 768px) {
.wsout5d35433c322bd {
display: block;
}
}
@media screen and (max-width: 767px) {
.wsout5d35433c322bd {
display: block;
}
}
</style>

<p><img class="aligncenter size-large wp-image-4627" src="https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-41_1.png?resize=850%2C612&#038;ssl=1" alt="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 35 fractional scaling,linux" width="850" height="612" srcset="https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-41_1.png?resize=1024%2C737&amp;ssl=1 1024w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-41_1.png?resize=150%2C108&amp;ssl=1 150w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-41_1.png?resize=300%2C216&amp;ssl=1 300w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-41_1.png?resize=768%2C553&amp;ssl=1 768w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-41_1.png?resize=104%2C74&amp;ssl=1 104w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-41_1.png?resize=850%2C612&amp;ssl=1 850w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-41_1.png?w=1363&amp;ssl=1 1363w" sizes="(max-width: 850px) 100vw, 850px" title="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 36 fractional scaling,linux" data-recalc-dims="1"></p>
<p>Notice how you can choose some values like 1.1, 1.2, 1.3&hellip; Those values do not exist in GNOME&rsquo;s control center, and in fact, as you will see later, not even in Windows 10. There&rsquo;s just some fixed values like 125% and 175% there.</p>
<p>However, one drawback here is that Firefox on KDE doesn&rsquo;t scale. Notice how small its components are compared with the other elements. I am not sure if this issue is only related to Firefox, or all other GTK applications for example:</p>
<p><img class="aligncenter size-large wp-image-4630" src="https://i0.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-43.png?resize=850%2C478&#038;ssl=1" alt="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 37 fractional scaling,linux" width="850" height="478" srcset="https://i0.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-43.png?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-43.png?resize=150%2C84&amp;ssl=1 150w, https://i0.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-43.png?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-43.png?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-43.png?resize=850%2C478&amp;ssl=1 850w, https://i0.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_14-43.png?w=1700&amp;ssl=1 1700w" sizes="(max-width: 850px) 100vw, 850px" title="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 38 fractional scaling,linux" data-recalc-dims="1"></p>
<p>Steam and Telegram were scaled with no problem. It was just Firefox who was having an issue. As a small workaround, I found a Firefox extension called &ldquo;<a href="https://addons.mozilla.org/en-US/firefox/addon/zoom-page-we/" target="_blank" rel="noopener">Zoom Page WE</a>&rdquo; that increases the zoom level on all website to whatever level you choose. So in this case, I used it to automatically increase everything to 120%.</p>
<p>I didn&rsquo;t face any issues in Steam while playing a game and change the levels of brightness/volume, it&rsquo;s just working.</p>
<h3 id="other-desktops"><span class="ez-toc-section" id="Other_Desktops">Other Desktops<a class="anchorlink dashicons-before" href="#other-desktops"></a></span></h3>
<p>The GNOME&rsquo;s Wayland compositor does support the same scaling in Xorg. The KDE Wayland Compositor developers have been working on a solution for a while, and you can check their progress from <a href="https://gitlab.freedesktop.org/xorg/xserver/merge_requests/111" target="_blank" rel="noopener">GitLab</a>.</p>
<p>It also sounds like Sway (Which is an i3-like compositor) <a href="https://wiki.archlinux.org/index.php/Sway#HiDPI" target="_blank" rel="noopener">does support</a> HiDPI scaling so far. But I haven&rsquo;t tested it personally.</p>
<p>Xfce doesn&rsquo;t support HiDPI scaling, same is true for MATE (Which is normal since they written in the same GTK toolkit).</p>
<h2 id="fractional-scaling-hidpi-support-on-windows-10"><span class="ez-toc-section" id="Fractional_Scaling_HiDPI_Support_on_Windows_10">Fractional Scaling (HiDPI) Support on Windows 10<a class="anchorlink dashicons-before" href="#fractional-scaling-hidpi-support-on-windows-10"></a></span></h2>
<p>I have to admit that HiDPI support on Windows is the best one available in the market. In Windows, if the system detects that your display is actually too large in terms of pixels, then scaling will be <strong>automatically</strong> applied for you.</p>
<p>Just directly after installing a fresh copy of Windows 10, I noticed that the system is already set to a scale of 125%:</p>
<figure id="attachment_4619" aria-describedby="caption-attachment-4619" style="width: 850px" class="wp-caption aligncenter"><img class="size-large wp-image-4619" src="https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-1.png?resize=850%2C478&#038;ssl=1" alt="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 39 fractional scaling,linux" width="850" height="478" srcset="https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-1.png?resize=1024%2C576&amp;ssl=1 1024w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-1.png?resize=150%2C84&amp;ssl=1 150w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-1.png?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-1.png?resize=768%2C432&amp;ssl=1 768w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-1.png?resize=850%2C478&amp;ssl=1 850w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-1.png?w=1700&amp;ssl=1 1700w" sizes="(max-width: 850px) 100vw, 850px" title="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 40 fractional scaling,linux" data-recalc-dims="1"><figcaption id="caption-attachment-4619" class="wp-caption-text">Automatic Fractional Scaling on Windows 10</figcaption></figure>
<p>In comparison, notice how a normal 100% scale would look like:</p>
<p><img class="aligncenter size-large wp-image-4620" src="https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-3.png?resize=850%2C478&#038;ssl=1" alt="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 41 fractional scaling,linux" width="850" height="478" srcset="https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-3.png?resize=1024%2C576&amp;ssl=1 1024w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-3.png?resize=150%2C84&amp;ssl=1 150w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-3.png?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-3.png?resize=768%2C432&amp;ssl=1 768w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-3.png?resize=850%2C478&amp;ssl=1 850w, https://i2.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-3.png?w=1700&amp;ssl=1 1700w" sizes="(max-width: 850px) 100vw, 850px" title="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 42 fractional scaling,linux" data-recalc-dims="1"></p>
<p>There are some other options to choose from too, but it sounds like Windows can&rsquo;t be tweaked into using some other manual values (E.g 135%), but I think those ones are quite more than enough for my display:</p>
<p><img class="aligncenter size-large wp-image-4621" src="https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-2.png?resize=850%2C604&#038;ssl=1" alt="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 43 fractional scaling,linux" width="850" height="604" srcset="https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-2.png?resize=1024%2C728&amp;ssl=1 1024w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-2.png?resize=150%2C107&amp;ssl=1 150w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-2.png?resize=300%2C213&amp;ssl=1 300w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-2.png?resize=768%2C546&amp;ssl=1 768w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-2.png?resize=104%2C74&amp;ssl=1 104w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-2.png?resize=850%2C604&amp;ssl=1 850w, https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/Windows-2.png?w=1321&amp;ssl=1 1321w" sizes="(max-width: 850px) 100vw, 850px" title="The Status of Fractional Scaling (HiDPI) Between Windows &amp; Linux 44 fractional scaling,linux" data-recalc-dims="1"></p>
<p>What&rsquo;s actually nice on Windows is that everything scales with no issues too: Steam, Telegram, Firefox&hellip; Every single app you have will look just as expected. There&rsquo;s no need to Google about &ldquo;how to enable experimental scaling in Windows&rdquo;, there&rsquo;s no need to ask for help in solving the bugs afterwards&hellip; It just works automatically out of the box.</p>
<p>And Windows support for HiDPI isn&rsquo;t something new like most Linux DEs. It has been available almost from the same time when those screens became available in the market. So the factor of availability of support is also important for the user. In GNOME, for example, the feature is still experimental.</p>
<h2 id="conclusion"><span class="ez-toc-section" id="Conclusion">Conclusion<a class="anchorlink dashicons-before" href="#conclusion"></a></span></h2>
<p>You&rsquo;ve seen how all of these working environments support HiDPI. It is fair to admit that having a multi-billion dollar company like Microsoft behind Windows is totally different than the small organizations or communities behind the famous Linux desktops, so of course the results are going to differ. Think of this article as as an explanation of the situation rather than pointing fingers to someone.</p><div class="dkhox5d35433c3248e" ><center>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block; text-align:center;"
     data-ad-layout="in-article"
     data-ad-format="fluid"
     data-ad-client="ca-pub-7543508590810245"
     data-ad-slot="3805338940"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center></div><style type="text/css">
@media screen and (min-width: 1201px) {
.dkhox5d35433c3248e {
display: block;
}
}
@media screen and (min-width: 993px) and (max-width: 1200px) {
.dkhox5d35433c3248e {
display: block;
}
}
@media screen and (min-width: 769px) and (max-width: 992px) {
.dkhox5d35433c3248e {
display: block;
}
}
@media screen and (min-width: 768px) and (max-width: 768px) {
.dkhox5d35433c3248e {
display: block;
}
}
@media screen and (max-width: 767px) {
.dkhox5d35433c3248e {
display: block;
}
}
</style>

<p>However, the progress is great so far, and we are almost there!</p>
<p>We hope this is going to improve by time.</p>
<div class="crestaStickButtonsEnd"></div></body></html>

							
							
						</div><!-- END Post Content. -->

						<footer>
							
							
							
							
	<div class="bdaia-p-bottom-e3-desktop"><div class="bdaia-e3-container"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-7543508590810245"
     data-ad-slot="3084967453"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>

							
							<div class="bdaia-author-box">

	<div class="authorBlock-avatar">
		<a href="https://fosspost.org/author/mhsabbagh"><img alt='' src='https://secure.gravatar.com/avatar/52048a44c42871762df69736d27a11bd?s=150&#038;r=g' srcset='https://secure.gravatar.com/avatar/52048a44c42871762df69736d27a11bd?s=300&#038;r=g 2x' class='avatar avatar-150 photo' height='150' width='150' /></a>
	</div>

	<div class="authorBlock-header">

		<h3 class="authorBlock-header-title">
			<a href="https://fosspost.org/author/mhsabbagh">M.Hanny Sabbagh		</h3>

		<p class="authorBlock-header-bio">
			Python programmer and open source software enthusiast. Worked on developing a lot of free software. The founder of FOSS Post and FOSS Project. Computer Science major.		</p>

		<div class="authorBlock-meta bdaia-social-io-colored">
			<div class="bdaia-social-io bdaia-social-io-size-32">
									<a class="bdaia-io-url-home" href="http://blog.mhsabbagh.com"><span class="bdaia-io bdaia-io-home3"></span></a>
				
									<a class="bdaia-io-url-twitter" href="http://www.twitter.com/realmhsabbagh"><span class="bdaia-io bdaia-io-twitter"></span></a>
				
				
				
				
				
				
				
				
							</div>
		</div>

	</div>
</div>
<!-- END Author Box. -->						</footer>

						<span style=display:none itemprop=author itemscope itemtype="https://schema.org/Person">
	<meta itemprop=name content="M.Hanny Sabbagh">
</span>

<meta itemprop=interactionCount content="UserComments:1">

<meta itemprop=datePublished content="2019-07-21T21:40:04+00:00">
<meta itemprop=dateModified content="2019-07-21T21:40:04+00:00">

<meta itemscope itemprop=mainEntityOfPage itemtype="https://schema.org/WebPage" itemid="https://fosspost.org/analytics/fractional-scaling-between-windows-linux">
<span style=display:none itemprop=publisher itemscope itemtype="https://schema.org/Organization">
	<span style=display:none itemprop=logo itemscope itemtype="https://schema.org/ImageObject">
		<meta itemprop="url" content="https://fosspost.org/wp-content/uploads/2017/08/logo-1-1.png">
	</span>
	<meta itemprop=name content="FOSS Post">
</span>
<meta itemprop=headline content="The Status of Fractional Scaling (HiDPI) Between Windows &#038; Linux">
<span style=display:none itemprop=image itemscope itemtype="https://schema.org/ImageObject">
	<meta itemprop=url content="https://i1.wp.com/fosspost.org/wp-content/uploads/2019/07/2019-07-21_21-22.png?fit=1920%2C964&#038;ssl=1">
	<meta itemprop=width content=1240>
	<meta itemprop=height content=540>
</span>
					</article>

					
						<div id="comments" class="comments-container">
		<h4 class="block-title"><span>One Comment</span></h4>
		<ol class="commentlist">
				<li class="comment even thread-even depth-1 comment-box" id="comment-8179">
		<div class="comment-header">
			<img alt='' src='https://secure.gravatar.com/avatar/fc34f0bec9be8fb157d3eba121d7f46a?s=50&#038;r=g' srcset='https://secure.gravatar.com/avatar/fc34f0bec9be8fb157d3eba121d7f46a?s=100&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />			<h3>TiTAN</h3>
			<p class="comment-meta">
				July 21, 2019 at 9:56 pm</a>			</p>
		</div>
		<div class="comment-body">
			<p>
								<p>I have very very problem with HiDPI on Ubuntu , i test 16.04 18.04 19.04<br />
https://gitlab.gnome.org/GNOME/mutter/issues/654</p>
			</p>
			<p class="tm-js-reply">
				<a rel='nofollow' class='comment-reply-link' href='#comment-8179' data-commentid="8179" data-postid="4617" data-belowelement="comment-8179" data-respondelement="respond" aria-label='Reply to TiTAN'><i class="icon-mail-reply"></i> Reply</a>			</p>
		</div>
	</li>
	</li><!-- #comment-## -->
		</ol>
		<div class="comments-navigation">
			<div class="alignleft"></div>
			<div class="alignright"></div>
		</div>
	</div>
		<div id="respond" class="comment-respond">
		<h4 class="block-title" id="reply-title"><span class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/analytics/fractional-scaling-between-windows-linux#respond" style="display:none;">Cancel reply</a></small></span></h4>			<form action="https://fosspost.org/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='4617' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="828aae9c9d" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="148"/></p>			</form>
			</div><!-- #respond -->
	
				
							</div>

		</div>
		<!-- END Content. -->

	</div>


</div>
						                                                                        <div class="bdaia-footer">
	                        
		<div class="bdaia-footer-widgets">
		<div class="bd-container">
			<div class="bdaia-footer-widgets-area footer-col-four">

									<div id="footer-first" class="footer-widget-inner">
						<div id="text-6" class="widget bdaia-widget widget_text">
<h4 class="block-title"><span>PPAs.fosspost.org</span></h4>
<div class="widget-inner">
			<div class="textwidget"><p><a href="https://ppas.fosspost.org"><img class="aligncenter  wp-image-4315" src="https://i1.wp.com/fosspost.org/wp-content/uploads/2019/04/Ubuntu-Packages-with-GiftWrap.jpg?resize=146%2C161&#038;ssl=1" alt="" width="146" height="161" data-recalc-dims="1" /></a>We have created a special page for you which contains a list of good PPAs to add to your Ubuntu system whenever you need (E.g new installations). Check it out at <a href="http://ppas.fosspost.org">ppas.fosspost.org</a>.</p>
</div>
		</div>
</div>					</div>
				
									<div id="footer-second" class="footer-widget-inner">
						<div id="text-5" class="widget bdaia-widget widget_text">
<h4 class="block-title"><span>Subscribe to Newsletter</span></h4>
<div class="widget-inner">
			<div class="textwidget"><p><script type="text/javascript" src="https://static.mailerlite.com/data/webforms/533801/x1s4c8.js?v4"></script></p>
</div>
		</div>
</div>					</div>
				
									<div id="footer-third" class="footer-widget-inner">
						<div id="archives-3" class="widget bdaia-widget widget_archive">
<h4 class="block-title"><span>Archives</span></h4>
<div class="widget-inner">
		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://fosspost.org/2019/07'> July 2019 &nbsp;(4)</option>
	<option value='https://fosspost.org/2019/06'> June 2019 &nbsp;(4)</option>
	<option value='https://fosspost.org/2019/05'> May 2019 &nbsp;(1)</option>
	<option value='https://fosspost.org/2019/04'> April 2019 &nbsp;(2)</option>
	<option value='https://fosspost.org/2019/03'> March 2019 &nbsp;(1)</option>
	<option value='https://fosspost.org/2019/02'> February 2019 &nbsp;(5)</option>
	<option value='https://fosspost.org/2018/12'> December 2018 &nbsp;(4)</option>
	<option value='https://fosspost.org/2018/11'> November 2018 &nbsp;(1)</option>
	<option value='https://fosspost.org/2018/10'> October 2018 &nbsp;(2)</option>
	<option value='https://fosspost.org/2018/09'> September 2018 &nbsp;(1)</option>
	<option value='https://fosspost.org/2018/08'> August 2018 &nbsp;(1)</option>
	<option value='https://fosspost.org/2018/07'> July 2018 &nbsp;(2)</option>
	<option value='https://fosspost.org/2018/05'> May 2018 &nbsp;(1)</option>
	<option value='https://fosspost.org/2018/04'> April 2018 &nbsp;(4)</option>
	<option value='https://fosspost.org/2018/03'> March 2018 &nbsp;(1)</option>
	<option value='https://fosspost.org/2018/02'> February 2018 &nbsp;(1)</option>
	<option value='https://fosspost.org/2017/11'> November 2017 &nbsp;(2)</option>
	<option value='https://fosspost.org/2017/10'> October 2017 &nbsp;(1)</option>
	<option value='https://fosspost.org/2017/09'> September 2017 &nbsp;(1)</option>
	<option value='https://fosspost.org/2017/08'> August 2017 &nbsp;(3)</option>
	<option value='https://fosspost.org/2017/07'> July 2017 &nbsp;(5)</option>
	<option value='https://fosspost.org/2017/06'> June 2017 &nbsp;(6)</option>
	<option value='https://fosspost.org/2017/05'> May 2017 &nbsp;(1)</option>
	<option value='https://fosspost.org/2017/04'> April 2017 &nbsp;(3)</option>
	<option value='https://fosspost.org/2017/03'> March 2017 &nbsp;(2)</option>
	<option value='https://fosspost.org/2017/02'> February 2017 &nbsp;(7)</option>
	<option value='https://fosspost.org/2017/01'> January 2017 &nbsp;(3)</option>
	<option value='https://fosspost.org/2016/10'> October 2016 &nbsp;(1)</option>
	<option value='https://fosspost.org/2016/09'> September 2016 &nbsp;(3)</option>
	<option value='https://fosspost.org/2016/08'> August 2016 &nbsp;(3)</option>
	<option value='https://fosspost.org/2016/07'> July 2016 &nbsp;(7)</option>

		</select>

<script type='text/javascript'>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-3" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</div>
</div>					</div>
				
									<div id="footer-fourth" class="footer-widget-inner">
						<div id="bdaia-widget-comments-6" class="widget bdaia-widget bdaia-widget-comments"><h4 class="block-title"><span>Latest Comments</span></h4>
<div class="widget-inner">

							<div class="bdaia-wb-comments">
					<div class="bdaia-wbc-inner">
						<div class="bdaia-wbc-avatar">
							<img alt='' src='https://secure.gravatar.com/avatar/fc34f0bec9be8fb157d3eba121d7f46a?s=55&#038;r=g' srcset='https://secure.gravatar.com/avatar/fc34f0bec9be8fb157d3eba121d7f46a?s=110&#038;r=g 2x' class='avatar avatar-55 photo' height='55' width='55' />						</div>
						<div class="bdaia-wbc-comment">
							<h3 class="entry-title">
								<a href="https://fosspost.org/analytics/fractional-scaling-between-windows-linux#comment-8179">
									<span>TiTAN: I have very very problem with HiDPI on Ubuntu , i test 16.04 18.04 19.04 https:/...</span>
								</a>
							</h3>
						</div>
					</div>
				</div>
							<div class="bdaia-wb-comments">
					<div class="bdaia-wbc-inner">
						<div class="bdaia-wbc-avatar">
							<img alt='' src='https://secure.gravatar.com/avatar/52048a44c42871762df69736d27a11bd?s=55&#038;r=g' srcset='https://secure.gravatar.com/avatar/52048a44c42871762df69736d27a11bd?s=110&#038;r=g 2x' class='avatar avatar-55 photo' height='55' width='55' />						</div>
						<div class="bdaia-wbc-comment">
							<h3 class="entry-title">
								<a href="https://fosspost.org/tutorials/burn-windows-on-usb-linux#comment-8138">
									<span>M.Hanny Sabbagh: WebUpd8 PPA has some autobuilds working, so the new updated versions aren't actu...</span>
								</a>
							</h3>
						</div>
					</div>
				</div>
							<div class="bdaia-wb-comments">
					<div class="bdaia-wbc-inner">
						<div class="bdaia-wbc-avatar">
							<img alt='' src='https://secure.gravatar.com/avatar/8c95b264cdd1b06828ad52a8e3e2deef?s=55&#038;r=g' srcset='https://secure.gravatar.com/avatar/8c95b264cdd1b06828ad52a8e3e2deef?s=110&#038;r=g 2x' class='avatar avatar-55 photo' height='55' width='55' />						</div>
						<div class="bdaia-wbc-comment">
							<h3 class="entry-title">
								<a href="https://fosspost.org/tutorials/burn-windows-on-usb-linux#comment-8133">
									<span>riot: I've seen this before but never took the time to give it a try. I guess I just d...</span>
								</a>
							</h3>
						</div>
					</div>
				</div>
							<div class="bdaia-wb-comments">
					<div class="bdaia-wbc-inner">
						<div class="bdaia-wbc-avatar">
							<img alt='' src='https://secure.gravatar.com/avatar/52048a44c42871762df69736d27a11bd?s=55&#038;r=g' srcset='https://secure.gravatar.com/avatar/52048a44c42871762df69736d27a11bd?s=110&#038;r=g 2x' class='avatar avatar-55 photo' height='55' width='55' />						</div>
						<div class="bdaia-wbc-comment">
							<h3 class="entry-title">
								<a href="https://fosspost.org/opinions/amd-on-linux#comment-8102">
									<span>M.Hanny Sabbagh: I bought it from a local shop in Turkey. It came preinstalled with no request/fe...</span>
								</a>
							</h3>
						</div>
					</div>
				</div>
			
		</div>
</div>					</div>
				
			</div>
		</div>
	</div><!--Widgets/-->

	                        
	                        		                        <div class="woohoo-footer-top-area">
			                        			                        				                        <div class="bd-container">
					                        <div class="bdaia-row">
						                        						                        						                        						                            <div class="footer-col3">
							                            <h4 class="block-title"><span>Follow us</span></h4>
							                            <div class="widget-social-links bdaia-social-io-colored">
								                            <div class="bdaia-social-io bdaia-social-io-size-35">
<a class="none bdaia-io-url-facebook" title="Facebook" href="https://facebook.com/fosspost" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class="none bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/fosspost" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class="none bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/channel/UC-LJRjAuZz9lVICSseyvE2A" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class="none bdaia-io-url-rss" title="Rss" href="https://fosspost.org/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div>							                            </div>
						                            </div>
						                        					                        </div>
				                        </div>
			                        			                        				                        <div class="bd-container">
					                        <div class="woohoo-footer-menu">
						                        <div class="menu-pages-container"><ul id="menu-pages" class="footer-bottom-menu"><li id="menu-item-538" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-538"><a href="https://fosspost.org/about">About FOSS Post</a></li>
<li id="menu-item-3726" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-3726"><a href="https://fosspost.org/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-1541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1541"><a title="donate" href="https://fosspost.org/donate">Donate</a></li>
<li id="menu-item-4202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4202"><a href="https://fosspost.org/sponsorship">Sponsorship</a></li>
<li id="menu-item-540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-540"><a href="https://fosspost.org/contact-us">Contact Us</a></li>
<li id="menu-item-2369" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2369"><a href="https://fosspost.org/submit-an-article">Submit an Article</a></li>
</ul></div>					                        </div>
				                        </div>
			                        		                        </div>
	                        
	                        <div class="bdaia-footer-area">
		                        <div class="bd-container">
			                        <div class="bdaia-footer-area-l">
				                        <span class="copyright"><a rel="license" href="http://creativecommons.org/licenses/by-nc-sa/4.0/"><img alt="Creative Commons License" style="border-width:0" src="https://i.creativecommons.org/l/by-nc-sa/4.0/88x31.png" /></a>
</span>			                        </div>
			                        <div class="bdaia-footer-area-r">
				                        					                        <div class="bdaia-social-io bdaia-social-io-size-32">
<a class=" bdaia-io-url-facebook" title="Facebook" href="https://facebook.com/fosspost" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class=" bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/fosspost" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class=" bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/channel/UC-LJRjAuZz9lVICSseyvE2A" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class=" bdaia-io-url-rss" title="Rss" href="https://fosspost.org/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div>				                        			                        </div>
		                        </div>
	                        </div>
                        </div><!--.bdaia-footer/-->
                    </div>
                </div>
            </div><!-- #page/-->
        </div><!-- .page-outer/-->

        
        <!-- Popups v1.9.3.6 - https://wordpress.org/plugins/popups/ --><style type="text/css">
#spu-4535 .spu-close{
	font-size: 0;
	color:#c4c4c4;
	text-shadow: 0 1px 0 #fff;
}
#spu-4535 .spu-close:hover{
	color:#000;
}
#spu-4535 {
	background-color: #300047;
	background-color: rgb(48,0,71);
	color: #333;
	padding: 10px;
		border-radius: 10px;
	-moz-border-radius: 10px;
	-webkit-border-radius: 10px;
	-moz-box-shadow:  0px 0px 11px 2px #666;
	-webkit-box-shadow:  0px 0px 11px 2px #666;
	box-shadow:  0px 0px 11px 2px #666;
	width: 225px;

}
#spu-bg-4535 {
	opacity: 0;
	background-color: #af00db;
}
/*
		* Add custom CSS for this popup
		* Be sure to start your rules with #spu-4535 { } and use !important when needed to override plugin rules
		*/
		
		.spu-box {
		border-top: 1.66666em solid rgba(85, 85, 85, 0.333);
		}</style>
<div class="spu-bg" id="spu-bg-4535"></div>
<div class="spu-box  spu-bottom-right spu-total- " id="spu-4535"
 data-box-id="4535" data-trigger="percentage"
 data-trigger-number="15"
 data-spuanimation="slide" data-tconvert-cookie="h" data-tclose-cookie="h" data-dconvert-cookie="0" data-dclose-cookie="0" data-nconvert-cookie="spu_conversion_4535" data-nclose-cookie="spu_closing_4535" data-test-mode="0"
 data-auto-hide="1" data-close-on-conversion="" data-bgopa="0" data-total=""
 style="left:-99999px !important;right:auto;" data-width="225" >
	<div class="spu-content"><h3 style="text-align: center;"><span style="color: #ffffff;">OpenPigeon Telegram Channel</span></h3>
<p><img class="aligncenter wp-image-4605" src="https://fosspost.org/wp-content/uploads/2019/07/telegram-icon.png" alt="" width="96" height="96" /></p>
<p style="text-align: center;"><span style="color: #ffffff;">Get the latest stories, articles and news about open source software on daily basis via the OpenPigeon Telegram channel!</span></p>
<p style="text-align: center;"><span style="color: #99ccff;"><a style="color: #99ccff;" href="https://t.me/joinchat/AAAAAESRuBUmmkOCjy93jA">Join OpenPigeon Channel</a></span></p>
</div>
	<span class="spu-close spu-close-popup top_right"><i class="spu-icon spu-icon-close"></i></span>
	<span class="spu-timer"></span>
	</div>
<!-- / Popups Box -->
<div id="fb-root" class=" fb_reset"></div><!--www.crestaproject.com Cresta Social Share Counter Floating Start--><div id="crestashareicon" class="cresta-share-icon right sameColors fourth_style show-count-active"><div class="sbutton crestaShadow facebook-cresta-share" data-anim="wobble" id="facebook-cresta"><a rel="nofollow" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffosspost.org%2Fanalytics%2Ffractional-scaling-between-windows-linux&amp;t=The+Status+of+Fractional+Scaling+%28HiDPI%29+Between+Windows+%26+Linux" data-name="Share to Facebook" onclick="window.open(this.href,'targetWindow','toolbars=0,location=0,status=0,menubar=0,scrollbars=1,resizable=1,width=640,height=320,left=200,top=200');return false;"><i class="cs c-icon-cresta-facebook"></i></a></div><div class="sbutton crestaShadow twitter-cresta-share noCount noCountTwo withCountThree" data-anim="wobble" id="twitter-cresta"><a rel="nofollow" href="https://twitter.com/intent/tweet?text=The+Status+of+Fractional+Scaling+%28HiDPI%29+Between+Windows+%26+Linux&amp;url=https%3A%2F%2Ffosspost.org%2Fanalytics%2Ffractional-scaling-between-windows-linux&amp;via=fosspost" data-name="Share to Twitter" onclick="window.open(this.href,'targetWindow','toolbars=0,location=0,status=0,menubar=0,scrollbars=1,resizable=1,width=640,height=320,left=200,top=200');return false;"><i class="cs c-icon-cresta-twitter"></i></a></div><div class="sbutton crestaShadow linkedin-cresta-share" data-anim="wobble" id="linkedin-cresta"><a rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Ffosspost.org%2Fanalytics%2Ffractional-scaling-between-windows-linux&amp;title=The+Status+of+Fractional+Scaling+%28HiDPI%29+Between+Windows+%26+Linux&amp;source=https://fosspost.org/" data-name="Share to Linkedin" onclick="window.open(this.href,'targetWindow','toolbars=0,location=0,status=0,menubar=0,scrollbars=1,resizable=1,width=640,height=320,left=200,top=200');return false;"><i class="cs c-icon-cresta-linkedin"></i></a></div><div class="sbutton crestaShadow reddit-cresta-share" data-anim="wobble" id="reddit-cresta"><a rel="nofollow" href="https://www.reddit.com/submit?url=https%3A%2F%2Ffosspost.org%2Fanalytics%2Ffractional-scaling-between-windows-linux&amp;title=The+Status+of+Fractional+Scaling+%28HiDPI%29+Between+Windows+%26+Linux" data-name="Share to Reddit" onclick="window.open(this.href,'targetWindow','toolbars=0,location=0,status=0,menubar=0,scrollbars=1,resizable=1,width=640,height=320,left=200,top=200');return false;"><i class="cs c-icon-cresta-reddit"></i></a></div><div class="sbutton crestaShadow whatsapp-cresta-share" data-anim="wobble" id="whatsapp-cresta"><a rel="nofollow" href="whatsapp://send?text=The%20Status%20of%20Fractional%20Scaling%20%28HiDPI%29%20Between%20Windows%20%26%20Linux - https%3A%2F%2Ffosspost.org%2Fanalytics%2Ffractional-scaling-between-windows-linux" data-name="Share to WhatsApp"><i class="cs c-icon-cresta-whatsapp"></i></a></div><div class="sbutton crestaShadow telegram-cresta-share" data-anim="wobble" id="telegram-cresta"><a rel="nofollow" href="tg://msg?text=The%20Status%20of%20Fractional%20Scaling%20%28HiDPI%29%20Between%20Windows%20%26%20Linux - https%3A%2F%2Ffosspost.org%2Fanalytics%2Ffractional-scaling-between-windows-linux" data-name="Share to Telegram"><i class="cs c-icon-cresta-telegram"></i></a></div><div class="sbutton crestaShadow email-cresta-share" data-anim="wobble" id="email-cresta"><a rel="nofollow" href="mailto:?subject=The%20Status%20of%20Fractional%20Scaling%20%28HiDPI%29%20Between%20Windows%20%26%23038%3B%20Linux&amp;body=https%3A%2F%2Ffosspost.org%2Fanalytics%2Ffractional-scaling-between-windows-linux" data-name="Share via Email" onclick="window.open(this.href,'targetWindow','toolbars=0,location=0,status=0,menubar=0,scrollbars=1,resizable=1,width=640,height=320,left=200,top=200');return false;"><i class="cs c-icon-cresta-mail"></i></a></div><div class="sbutton total-float" data-anim="wobble" id="total-shares"><span class="cresta-the-total-count" id="total-count"><i class="cs c-icon-cresta-spinner animate-spin"></i></span><span class="cresta-the-total-text">Shares</span></div></div><!--www.crestaproject.com Cresta Social Share Counter Floating End--><div id="pwaforwp-add-to-home-click" style="background-color:" class="pwaforwp-footer-prompt pwaforwp-bounceInUp pwaforwp-animated"><h3 style="color:">Add FOSS Post to your Homescreen!</h3><div style="background-color:; color:" class="pwaforwp-btn pwaforwp-btn-add-to-home">Add</div></div><div class="gotop" title="Go Top"><span class="bdaia-io bdaia-io-chevron-up"></span></div><div id="reading-position-indicator"></div>
<script>
    </script><script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.5.3/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/cresta-social-share-counter-pro/js/jquery.cresta-social-effect.js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/cresta-social-share-counter-pro/js/jquery.cresta-social-whatsapp.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var crestaSetting = {"distanceTop":"200","distanceLeft":"60"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/cresta-social-share-counter-pro/js/jquery.cresta-stick-buttons.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var crestaShareSSS = {"FacebookCount":"nope"};
var crestaPermalink = {"thePermalink":"https:\/\/fosspost.org\/analytics\/fractional-scaling-between-windows-linux","themorezero":"yesmore","totalmorezero":"totalyesmore","themorenumber":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/cresta-social-share-counter-pro/js/jquery.cresta-social-share-counter.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pwaforwp_obj = {"ajax_url":"https:\/\/fosspost.org\/wp-admin\/admin-ajax.php","pwa_ms_prefix":"","pwa_home_url":"https:\/\/fosspost.org\/","pwaforwp_security_nonce":"1b41ab8dad"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/pwa-for-wp/assets/js/pwa-push-notification.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/fosspost.org\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/wp-polls/polls-js.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var spuvar = {"is_admin":"","disable_style":"","ajax_mode":"","ajax_url":"https:\/\/fosspost.org\/wp-admin\/admin-ajax.php","ajax_mode_url":"https:\/\/fosspost.org\/?spu_action=spu_load","pid":"4617","is_front_page":"","is_category":"","site_url":"https:\/\/fosspost.org","is_archive":"","is_search":"","is_preview":"","seconds_confirmation_close":"5"};
var spuvar_social = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/popups/public/assets/js/public.js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/enlighter/resources/mootools-core-yc.js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/enlighter/resources/EnlighterJS.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bd = "{\"nonce\":\"cb7465e64d\",\"ajaxurl\":\"https:\\\/\\\/fosspost.org\\\/wp-admin\\\/admin-ajax.php\",\"is_singular\":true,\"has_lazy_load\":false,\"bd_lazyload\":false,\"mobile_topmenu\":false,\"sticky_sidebar\":true,\"all_lightbox\":true,\"click_to_comments\":false,\"post_reading_position_indicator\":\"1\"}";
/* ]]> */
</script>
<script type='text/javascript' src='https://fosspost.org/wp-content/themes/woohoo/js/main.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://fosspost.org/wp-content/plugins/akismet/_inc/form.js'></script>
<script type="text/javascript">/* <![CDATA[ */EnlighterJS_Config = {"selector":{"block":"pre.EnlighterJSRAW","inline":"code.EnlighterJSRAW"},"language":"generic","theme":"classic","indent":2,"hover":"hoverEnabled","showLinenumbers":true,"rawButton":true,"infoButton":false,"windowButton":true,"rawcodeDoubleclick":false,"grouping":true,"cryptex":{"enabled":false,"email":"mail@example.tld"}};!function(){var a=function(a){var b="Enlighter Error: ";console.error?console.error(b+a):console.log&&console.log(b+a)};return window.addEvent?"undefined"==typeof EnlighterJS?void a("Javascript Resources not loaded yet!"):"undefined"==typeof EnlighterJS_Config?void a("Configuration not loaded yet!"):void window.addEvent("domready",function(){EnlighterJS.Util.Init(EnlighterJS_Config.selector.block,EnlighterJS_Config.selector.inline,EnlighterJS_Config)}):void a("MooTools Framework not loaded yet!")}();;/* ]]> */</script><script src="https://fosspost.org/pwa-register-sw.js"></script><script type='text/javascript' src='https://stats.wp.com/e-201930.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.5.3',blog:'121649277',post:'4617',tz:'3',srv:'fosspost.org'} ]);
	_stq.push([ 'clickTrackerInit', '121649277', '4617' ]);
</script>
    </body>
</html>