<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#" class="no-js">
	<head>
		<meta charset="UTF-8">
		<meta http-equiv="X-UA-Compatible" content="IE=edge"/>
		<meta name="viewport" content="width=device-width, initial-scale=1, minimum-scale=1">
		<meta name="author" content="SeventhQueen"/>
		<link rel="profile" href="https://gmpg.org/xfn/11">
		<div class="irbjw61a3705e00f41" ><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7543508590810245"
     crossorigin="anonymous"></script></div><style type="text/css">
@media screen and (min-width: 1201px) {
.irbjw61a3705e00f41 {
display: block;
}
}
@media screen and (min-width: 993px) and (max-width: 1200px) {
.irbjw61a3705e00f41 {
display: block;
}
}
@media screen and (min-width: 769px) and (max-width: 992px) {
.irbjw61a3705e00f41 {
display: block;
}
}
@media screen and (min-width: 768px) and (max-width: 768px) {
.irbjw61a3705e00f41 {
display: block;
}
}
@media screen and (max-width: 767px) {
.irbjw61a3705e00f41 {
display: block;
}
}
</style>


					<script>document.documentElement.classList.remove('no-js');</script>
			
		
<!-- Search Engine Optimization by Rank Math - https://s.rankmath.com/home -->
<title>Linux Is Everywhere: 5 Places Where You Didn&#039;t Know It&#039;s There</title>
<meta name="description" content="Have you every wondered where is Linux? What key sectors does it power and in what areas is it commonly used?"/>
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://fosspost.org/5-places-powered-by-linux-exist/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Linux Is Everywhere: 5 Places Where You Didn&#039;t Know It&#039;s There" />
<meta property="og:description" content="Have you every wondered where is Linux? What key sectors does it power and in what areas is it commonly used?" />
<meta property="og:url" content="https://fosspost.org/5-places-powered-by-linux-exist/" />
<meta property="og:site_name" content="FOSS Post" />
<meta property="article:publisher" content="https://facebook.com/fosspost" />
<meta property="article:author" content="http://www.facebook.com/fosspost" />
<meta property="article:tag" content="News" />
<meta property="article:section" content="All Posts" />
<meta property="og:updated_time" content="2021-11-28T10:43:35+03:00" />
<meta property="og:image" content="https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk.jpg" />
<meta property="og:image:secure_url" content="https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk.jpg" />
<meta property="og:image:width" content="1600" />
<meta property="og:image:height" content="1200" />
<meta property="og:image:alt" content="text" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Linux Is Everywhere: 5 Places Where You Didn&#039;t Know It&#039;s There" />
<meta name="twitter:description" content="Have you every wondered where is Linux? What key sectors does it power and in what areas is it commonly used?" />
<meta name="twitter:site" content="@fosspost" />
<meta name="twitter:creator" content="@fosspost" />
<meta name="twitter:image" content="https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk.jpg" />
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://fosspost.org/#organization","name":"FOSS Post","logo":{"@type":"ImageObject","@id":"https://fosspost.org/#logo","url":"https://fosspost.org/wp-content/uploads/2020/09/fosspost.png","caption":"FOSS Post","inLanguage":"en-US","width":"512","height":"512"}},{"@type":"WebSite","@id":"https://fosspost.org/#website","url":"https://fosspost.org","name":"FOSS Post","publisher":{"@id":"https://fosspost.org/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk.jpg","url":"https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk.jpg","width":"1600","height":"1200","caption":"text","inLanguage":"en-US"},{"@type":"BreadcrumbList","@id":"https://fosspost.org/5-places-powered-by-linux-exist/#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://fosspost.org","name":"Home"}},{"@type":"ListItem","position":"2","item":{"@id":"https://fosspost.org/topics/news/","name":"News"}},{"@type":"ListItem","position":"3","item":{"@id":"https://fosspost.org/5-places-powered-by-linux-exist/","name":"Linux is Everywhere: 5 Places Where You Didn&#8217;t Know It&#8217;s There"}}]},{"@type":"Person","@id":"https://fosspost.org/author/fosspostteam/","name":"FOSS Post Team","url":"https://fosspost.org/author/fosspostteam/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/d5950c8ee5c1d31f65bb1daba6ab95df?s=96&amp;d=mm&amp;r=g","url":"https://secure.gravatar.com/avatar/d5950c8ee5c1d31f65bb1daba6ab95df?s=96&amp;d=mm&amp;r=g","caption":"FOSS Post Team","inLanguage":"en-US"},"worksFor":{"@id":"https://fosspost.org/#organization"}},{"@type":"WebPage","@id":"https://fosspost.org/5-places-powered-by-linux-exist/#webpage","url":"https://fosspost.org/5-places-powered-by-linux-exist/","name":"Linux Is Everywhere: 5 Places Where You Didn&#039;t Know It&#039;s There","datePublished":"2021-11-28T10:43:35+03:00","dateModified":"2021-11-28T10:43:35+03:00","author":{"@id":"https://fosspost.org/author/fosspostteam/"},"isPartOf":{"@id":"https://fosspost.org/#website"},"primaryImageOfPage":{"@id":"https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk.jpg"},"inLanguage":"en-US","breadcrumb":{"@id":"https://fosspost.org/5-places-powered-by-linux-exist/#breadcrumb"}},{"@type":"Article","headline":"Linux Is Everywhere: 5 Places Where You Didn&#039;t Know It&#039;s There","keywords":"Linux Everywhere","datePublished":"2021-11-28T10:43:35+03:00","dateModified":"2021-11-28T10:43:35+03:00","author":{"@id":"https://fosspost.org/author/fosspostteam/"},"publisher":{"@id":"https://fosspost.org/#organization"},"description":"Have you every wondered where is Linux? What key sectors does it power and in what areas is it commonly used?","name":"Linux Is Everywhere: 5 Places Where You Didn&#039;t Know It&#039;s There","@id":"https://fosspost.org/5-places-powered-by-linux-exist/#richSnippet","isPartOf":{"@id":"https://fosspost.org/5-places-powered-by-linux-exist/#webpage"},"image":{"@id":"https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://fosspost.org/5-places-powered-by-linux-exist/#webpage"}}]}</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel="amphtml" href="https://fosspost.org/5-places-powered-by-linux-exist/amp/" /><meta name="generator" content="AMP for WP 1.0.77.30"/><link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="FOSS Post &raquo; Feed" href="https://fosspost.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="FOSS Post &raquo; Comments Feed" href="https://fosspost.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="FOSS Post &raquo; Linux is Everywhere: 5 Places Where You Didn&#8217;t Know It&#8217;s There Comments Feed" href="https://fosspost.org/5-places-powered-by-linux-exist/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/fosspost.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=b51148037eea88f6c8986434872703e2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='bdaia_shorty-style-css'  href='https://fosspost.org/wp-content/plugins/bdaia-shortcodes/assets/style.css?ver=b51148037eea88f6c8986434872703e2' type='text/css' media='all' />
<link rel='stylesheet' id='mci-footnotes-jquery-tooltips-pagelayout-none-css'  href='https://fosspost.org/wp-content/plugins/footnotes/css/footnotes-jqttbrpl0.min.css?ver=2.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.8.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='wp-block-library-theme-inline-css' type='text/css'>
#start-resizable-editor-section{display:none}.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{font-family:Menlo,Consolas,monaco,monospace;color:#1e1e1e;padding:.8em 1em;border:1px solid #ddd;border-radius:4px}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-group.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto;opacity:.4}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}#end-resizable-editor-section{display:none}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/5.8.2/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/5.8.2/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='quads-style-css-css'  href='https://fosspost.org/wp-content/plugins/quick-adsense-reloaded/includes/gutenberg/dist/blocks.style.build.css?ver=2.0.35' type='text/css' media='all' />
<link rel='stylesheet' id='bdaia_shorty_stylesheet-css'  href='https://fosspost.org/wp-content/plugins/bdaia-shortcodes/assets/shortcodes.css?ver=b51148037eea88f6c8986434872703e2' type='text/css' media='all' />
<link rel='stylesheet' id='better-recent-comments-css'  href='https://fosspost.org/wp-content/plugins/better-recent-comments/assets/css/better-recent-comments.min.css?ver=b51148037eea88f6c8986434872703e2' type='text/css' media='all' />
<link rel='stylesheet' id='sq-notes-css'  href='https://fosspost.org/wp-content/plugins/typer-pro/core/elements/assets/css/notes/styles.css?ver=1.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='widgetopts-styles-css'  href='https://fosspost.org/wp-content/plugins/widget-options/assets/css/widget-options.css' type='text/css' media='all' />
<link rel='stylesheet' id='ez-icomoon-css'  href='https://fosspost.org/wp-content/plugins/easy-table-of-contents/vendor/icomoon/style.min.css?ver=2.0.17' type='text/css' media='all' />
<link rel='stylesheet' id='ez-toc-css'  href='https://fosspost.org/wp-content/plugins/easy-table-of-contents/assets/css/screen.min.css?ver=2.0.17' type='text/css' media='all' />
<style id='ez-toc-inline-css' type='text/css'>
div#ez-toc-container p.ez-toc-title {font-size: 120%;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}
</style>
<link rel='stylesheet' id='sq-auth-style-css'  href='https://fosspost.org/wp-content/plugins/typer-pro/core/elements/assets/css/auth.css?ver=b51148037eea88f6c8986434872703e2' type='text/css' media='all' />
<link rel='stylesheet' id='typer-global-css'  href='https://fosspost.org/wp-content/themes/typer/assets/css/index.css?ver=1.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='typer-icon-fonts-css'  href='https://fosspost.org/wp-content/themes/typer/assets/fonts/style.css?ver=1.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://fosspost.org/wp-content/plugins/tablepress/css/default.min.css?ver=1.14' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-official-css'  href='https://use.fontawesome.com/releases/v5.15.3/css/all.css' type='text/css' media='all' integrity="sha384-SZXxX4whJ79/gErwcOYf+zWLeJdY/qpuqC4cAa9rOGUstPomtqpuNWT9wdPEn2fk" crossorigin="anonymous" />
<link rel='stylesheet' id='fontawesome-css'  href='https://fosspost.org/wp-content/plugins/wp-review-pro/public/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp_review-style-css'  href='https://fosspost.org/wp-content/plugins/wp-review-pro/public/css/wp-review.css?ver=3.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='deeper-icon-css'  href='https://fosspost.org/wp-content/plugins/deeper-comments/views/css/package/iconfonts.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='deeper-comment-css'  href='https://fosspost.org/wp-content/plugins/deeper-comments/views/css/deeper.min.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-official-v4shim-css'  href='https://use.fontawesome.com/releases/v5.15.3/css/v4-shims.css' type='text/css' media='all' integrity="sha384-C2B+KlPW+WkR0Ld9loR1x3cXp7asA0iGVodhCoJ4hwrWm/d9qKS59BGisq+2Y0/D" crossorigin="anonymous" />
<style id='font-awesome-official-v4shim-inline-css' type='text/css'>
@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-brands-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-brands-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-brands-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-brands-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-brands-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-brands-400.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-solid-900.eot"),
		url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-solid-900.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-solid-900.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-solid-900.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-solid-900.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-solid-900.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-regular-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-regular-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-regular-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-regular-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-regular-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.3/webfonts/fa-regular-400.svg#fontawesome") format("svg");
unicode-range: U+F004-F005,U+F007,U+F017,U+F022,U+F024,U+F02E,U+F03E,U+F044,U+F057-F059,U+F06E,U+F070,U+F075,U+F07B-F07C,U+F080,U+F086,U+F089,U+F094,U+F09D,U+F0A0,U+F0A4-F0A7,U+F0C5,U+F0C7-F0C8,U+F0E0,U+F0EB,U+F0F3,U+F0F8,U+F0FE,U+F111,U+F118-F11A,U+F11C,U+F133,U+F144,U+F146,U+F14A,U+F14D-F14E,U+F150-F152,U+F15B-F15C,U+F164-F165,U+F185-F186,U+F191-F192,U+F1AD,U+F1C1-F1C9,U+F1CD,U+F1D8,U+F1E3,U+F1EA,U+F1F6,U+F1F9,U+F20A,U+F247-F249,U+F24D,U+F254-F25B,U+F25D,U+F267,U+F271-F274,U+F279,U+F28B,U+F28D,U+F2B5-F2B6,U+F2B9,U+F2BB,U+F2BD,U+F2C1-F2C2,U+F2D0,U+F2D2,U+F2DC,U+F2ED,U+F328,U+F358-F35B,U+F3A5,U+F3D1,U+F410,U+F4AD;
}
</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/10.3/css/jetpack.css' type='text/css' media='all' />
<style id='quads-styles-inline-css' type='text/css'>

    .quads-location ins.adsbygoogle {
        background: transparent !important;
    }
    
    .quads-ad-label { font-size: 12px; text-align: center; color: #333;}
</style>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/footnotes/js/jquery.tools.min.js?ver=1.2.7.redacted.2' id='mci-footnotes-jquery-tools-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/bdaia-shortcodes/assets/js/scripts.js?ver=b51148037eea88f6c8986434872703e2' id='bdaia_shorty_scripts-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/bdaia-shortcodes/assets/js/shorty-min.js?ver=b51148037eea88f6c8986434872703e2' id='bdaia_shorty_min-js'></script>
<!--[if lt IE 8]>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/json2.min.js' id='json2-js'></script>
<![endif]-->
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/deeper-comments/views/js/package/follow-conversion.js?ver=1.0.1' id='deeper-comment_follow_conversion-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-includes/js/tinymce/wp-tinymce.php?ver=b51148037eea88f6c8986434872703e2' id='dpr_tinymce_js-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/deeper-comments/views/js/package/clipboard.js?ver=1.0.1' id='deeper-commentclipboard-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/deeper-comments/views/js/package/jquery-confirm.js?ver=1.0.1' id='deeper-commentjconfirm-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/deeper-comments//views/js/plugins/emoji/plugin.min.js?ver=1.0.1' id='deeper_emoji_tinymce-js'></script>
<script type='text/javascript' id='deeper-comment-js-extra'>
/* <![CDATA[ */
var dpr = {"editor_title":"Add Your Comment","post_comment":"Submit","cancel":"Cancel","ok":"ok","sure":"sure","duplicate":"Duplicate Comment!","spam_error":"Spam Error!","error":"Error!","save_comment":"Send","empty":"Please write your comment here.","sure_delete":"Are you sure you want to delete this comment?","delete_cm":"Delete Comment","delete":"Delete","name":"FullName","email":"Email","username":"UserName","usernameOrEmail":"Username \/ Email Address","password":"Password","confirm_password":"Retype-Password","login":"Login","lost_pass":"Forgot password?","signup":"Signup","refresh":"Refresh","flag_cm":"Inappropriate Comment","sure_flag":"Are you sure you want to mark this comment as inappropriate?","nocomment":"I can't find the comment you mean!","copy_message":"The comment link  copied successfully!","copy_message_title":"Info","term_link":"","lost_url":"https:\/\/fosspost.org\/wp-login.php?action=lostpassword","adminajax":"https:\/\/fosspost.org\/wp-admin\/admin-ajax.php","rtl":"","captcha":"none","recaptcha":"","recaptcha_theme":"light","recaptcha_size":"normal","vkswitch":"off","tumblrswitch":"off","getpocketswitch":"off","pinterestswitch":"off","redditswitch":"on","whatsappswitch":"off","telegramswitch":"off","notification_listener":"","logged_in":"no","p_length":"5"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/deeper-comments/views/js/package/deeper.min.js?ver=1.0.1' id='deeper-comment-js'></script>
<script type='text/javascript' id='deeper-comment-js-after'>

			jQuery(document).ready(function() {
				jQuery(".dpr-discu-container_25087 .dpr-discu-box .dpr-discu-box-footer-metadata-like .dpr-cont-discu-like .dpr-discu-like").depcVote({
					id: "25087",
					nounce : "a19a064fd2",
					like: "like"
				});
				jQuery(".dpr-discu-container_25087 .dpr-discu-box .dpr-discu-box-footer-metadata-like .dpr-cont-discu-dislike .dpr-discu-dislike").depcVote({
					id: "25087",
					nounce : "a19a064fd2",
					like: "dislike"
				});
			});
		jQuery(document).ready(function() {
			jQuery(".dpr-discu-container_25087 .dpr-join-form .dpr-discu-submit").depcSubmitComment({
				id: "25087",
				nounce : "49dc92913a",
				reply : false,
				selector : ".dpr-join-form .dpr-discu-submit",
				logged   : "0",
				captcha : "off"
			});
			jQuery(".dpr-discu-container_25087 .dpr-discu-wrap .dpr-discu-box-footer .dpr-discu-reply-btn").depcSubmitComment({
				id: "25087",
				nounce : "49dc92913a",
				reply : true,
				selector : ".dpr-discu-wrap .dpr-discu-box-footer .dpr-discu-reply-btn",
				logged   : "0",
				captcha : "off"
			});
			jQuery(".dpr-discu-container_25087 .dpr-discu-wrap .dpr-discu-replies-wrap .dpr-tinymce-button .dpr_add_reply_comment").depcSubmitComment({
				id: "25087",
				nounce : "49dc92913a",
				reply : 1,
				selector : ".dpr-discu-wrap .dpr-discu-replies-wrap .dpr-tinymce-button .dpr_add_reply_comment"
			});
			jQuery(".dpr-discu-container_25087 .dpr-discu-main-loop-wrap .dpr-discu-wrap .dpr-discu-box .dpr-discu-link").depcHandyJs({
				id: "25087",
				nounce : "49dc92913a",
				mode : "copylink",
				selector : ".dpr-discu-wrap .dpr-discu-replies-wrap .dpr-tinymce-button .dpr_add_reply_comment"
			});
			jQuery(".dpr-discu-container_25087 .dpr-discu-main-loop-wrap .dpr-discu-wrap .dpr-discu-box .facebook").depcHandyJs({
				id: "25087",
				nounce : "49dc92913a",
				mode : "facebook",
				selector : ".dpr-discu-main-loop-wrap .dpr-discu-wrap .dpr-discu-box .facebook"
			});
		});
		
			jQuery(document).ready(function() {
				jQuery(".dpr-discu-container_25087 .dpr-switch-tab-wrap .dpr-switch-tab .dpr-switch-tab-trending .dpr-switch-tab-trending-a").depcFilter({
					id: "25087",
					nounce : "68ab1c91e7",
					action : "dpr_filter",
					type: "trending"
				});
				jQuery(".dpr-discu-container_25087 .dpr-switch-tab-wrap .dpr-switch-tab .dpr-switch-tab-popular .dpr-switch-tab-popular-a").depcFilter({
					nounce : "68ab1c91e7",
					action : "dpr_filter",
					id: "25087",
					type: "popular"
				});
				jQuery(".dpr-discu-container_25087 .dpr-switch-tab-wrap .dpr-switch-tab .dpr-switch-tab-oldest .dpr-switch-tab-oldest-a").depcFilter({
					id: "25087",
					nounce : "68ab1c91e7",
					action : "dpr_filter",
					type: "oldest"
				});
				jQuery(".dpr-discu-container_25087 .dpr-switch-tab-wrap .dpr-switch-tab .dpr-switch-tab-newest .dpr-switch-tab-newest-a").depcFilter({
					id: "25087",
					nounce : "68ab1c91e7",
					action : "dpr_filter",
					type: "newest"
				});
				jQuery(".dpr-discu-container_25087 .dpr-switch-tab-wrap .dpr-switch-search-wrap .dpr-discu-search").depcFilter({
					id: "25087",
					nounce : "68ab1c91e7",
					action : "dpr_filter",
					type: "key"
				});
			});
			jQuery(document).ready(function() {
				jQuery(".dpr-discu-container_25087 .dpr-discu-main-loop-wrap .dpr-loadmore-btn").depcLoadMore({
					id: "25087",
					nounce : "b109e1eeee",
					action: "dpr_loadmore"
				});
			});
</script>
<script type='text/javascript' id='quads_ads_front-js-extra'>
/* <![CDATA[ */
var quads_analytics = {"ajax_url":"https:\/\/fosspost.org\/wp-admin\/admin-ajax.php","quads_front_nonce":"97a41991f0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/quick-adsense-reloaded/assets/js/performance_tracking.min.js?ver=2.0.35' id='quads_ads_front-js'></script>
<link rel="https://api.w.org/" href="https://fosspost.org/wp-json/" /><link rel="alternate" type="application/json" href="https://fosspost.org/wp-json/wp/v2/posts/25087" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://fosspost.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://fosspost.org/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://fosspost.org/?p=25087' />
<link rel="alternate" type="application/json+oembed" href="https://fosspost.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffosspost.org%2F5-places-powered-by-linux-exist%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://fosspost.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffosspost.org%2F5-places-powered-by-linux-exist%2F&#038;format=xml" />
<style id="wplmi-inline-css" type="text/css"> span.wplmi-user-avatar { width: 16px;display: inline-block !important;flex-shrink: 0; } img.wplmi-elementor-avatar { border-radius: 100%;margin-right: 3px; } 

</style>
 <script>
                  (adsbygoogle = window.adsbygoogle || []).push({
                  google_ad_client: "ca-pub-7543508590810245",
                  enable_page_level_ads: true
                  }); 
                 </script><script src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type='text/javascript'>document.cookie = 'quads_browser_width='+screen.width;</script><style type='text/css'>img#wpstats{display:none}</style>
		<link rel="preload" id="typer-global-preload" href="https://fosspost.org/wp-content/themes/typer/assets/css/index.css?ver=1.9.7" as="style">
    <script>
		if(screen.width<769){
        	window.location = "https://fosspost.org/5-places-powered-by-linux-exist/amp/";
        }
    	</script>
<style id="uagb-style-conditional-extension">@media (min-width: 1025px){body .uag-hide-desktop.uagb-google-map__wrap,body .uag-hide-desktop{display:none}}@media (min-width: 768px) and (max-width: 1024px){body .uag-hide-tab.uagb-google-map__wrap,body .uag-hide-tab{display:none}}@media (max-width: 767px){body .uag-hide-mob.uagb-google-map__wrap,body .uag-hide-mob{display:none}}</style><link rel="icon" href="https://fosspost.org/wp-content/uploads/2020/07/cropped-fosspost-7-32x32.png" sizes="32x32" />
<link rel="icon" href="https://fosspost.org/wp-content/uploads/2020/07/cropped-fosspost-7-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://fosspost.org/wp-content/uploads/2020/07/cropped-fosspost-7-180x180.png" />
<meta name="msapplication-TileImage" content="https://fosspost.org/wp-content/uploads/2020/07/cropped-fosspost-7-270x270.png" />
<script>
var gainwpDnt = false;
var gainwpProperty = 'UA-103104994-2';
var gainwpDntFollow = false;
var gainwpOptout = true;
var disableStr = 'ga-disable-' + gainwpProperty;
if(gainwpDntFollow && (window.doNotTrack === "1" || navigator.doNotTrack === "1" || navigator.doNotTrack === "yes" || navigator.msDoNotTrack === "1")) {
	gainwpDnt = true;
}
if (gainwpDnt || (document.cookie.indexOf(disableStr + '=true') > -1 && gainwpOptout)) {
	window[disableStr] = true;
}
function gaOptout() {
	var expDate = new Date;
	expDate.setFullYear(expDate.getFullYear( ) + 10);
	document.cookie = disableStr + '=true; expires=' + expDate.toGMTString( ) + '; path=/';
	window[disableStr] = true;
}
</script>

<!-- BEGIN GAINWP v5.4.6 Universal Analytics - https://intelligencewp.com/google-analytics-in-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-103104994-2', 'auto');
  ga('require', 'displayfeatures');
  ga('require', 'linkid');
  ga('set', 'anonymizeIp', true);
  ga('send', 'pageview');
</script>
<!-- END GAINWP Universal Analytics -->
		<style type="text/css" id="wp-custom-css">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</style>
		<style id="typer-css-vars">:root{--layout-max-width:1170px;--body-bg-h:0;--body-bg-s:0%;--body-bg-l:100%;--body-bg-contrast-color:#000000;--text-color:#212121;--heading-color:#212121;--primary-h:0;--primary-s:57%;--primary-l:40%;--primary-contrast-color:#ffffff;--light-h:36;--light-s:33%;--light-l:97%;--light-contrast-color:#000000;--dark-h:0;--dark-s:0%;--dark-l:14%;--dark-contrast-color:#ffffff;--link-h:0;--link-s:57%;--link-l:40%;--link-contrast-color:#ffffff;--border-color:#f1ece4;--text-meta-color:#a02c2c;--font-family:Source Sans Pro;--font-size-sm:1.1rem;--font-size-md:1.13rem;--font-size-lg:1.4rem;--line-height-sm:1.8;--line-height-md:1.6;--line-height-lg:1.8;--heading-font-family:Source Serif Pro;--h1-font-weight:regular;--h2-font-weight:regular;--h3-font-weight:regular;--h4-font-weight:regular;--h5-font-weight:regular;--h6-font-weight:regular;--heading-line-height:1.2;--h1-font-size-sm:1.88rem;--h1-font-size-md:2.63rem;--h1-font-size-lg:2.8rem;--h2-font-size-sm:1.7rem;--h2-font-size-md:1.8rem;--h2-font-size-lg:2.3rem;--h3-font-size-sm:1.2rem;--h3-font-size-md:1.6rem;--h3-font-size-lg:1.9rem;--h4-font-size-sm:1.25rem;--h4-font-size-md:1.5rem;--h4-font-size-lg:1.55rem;--h5-font-size-sm:1.13rem;--h5-font-size-md:1.25rem;--h5-font-size-lg:1.5rem;--h6-font-size-sm:1rem;--h6-font-size-md:1rem;--h6-font-size-lg:1rem;--quote-font-family:Noto Serif;--line-clamp-related-list-title:2;--related-color:#faf8f5;--related-h:36;--related-s:33%;--related-l:97%;--related-contrast-color:#000000;--footer-bg-h:0;--footer-bg-s:0%;--footer-bg-l:7%;--footer-bg-contrast-color:#ffffff;--media-max-height:800px;--fs-featured-section-title-sm:1.31rem;--fs-featured-section-title-md:1.75rem;--fs-featured-section-title-lg:2.13rem;--fs-featured-art-list-title-sm:1.75rem;--fs-featured-art-list-title-md:1.75rem;--fs-featured-art-list-title-lg:1.75rem;--line-clamp-featured-list-title:2;--featured-color:#fff3e0;--featured-h:37;--featured-s:100%;--featured-l:94%;--featured-contrast-color:#000000;--fs-article-list-title-sm:1.31rem;--fs-article-list-title-md:1.5rem;--fs-article-list-title-lg:1.75rem;--line-clamp-list-title:2;--fs-article-list-sm:1rem;--fs-article-list-md:1rem;--fs-article-list-lg:1.15rem;--line-clamp-list-text:6;--fs-article-big-title-sm:1.5rem;--fs-article-big-title-md:1.75rem;--fs-article-big-title-lg:2.25rem;--line-clamp-big-title:2;--fs-article-big-sm:1rem;--fs-article-big-md:1rem;--fs-article-big-lg:1.25rem;--fs-article-card-title-sm:1.2rem;--fs-article-card-title-md:1.5rem;--fs-article-card-title-lg:1.4rem;--line-clamp-card-title:3;--line-clamp-grid-title:3;--fs-article-list-card-sm:1rem;--fs-article-list-card-md:1rem;--fs-article-list-card-lg:1.15rem;--archive-color:#3587d8;--archive-h:210;--archive-s:68%;--archive-l:53%;--archive-contrast-color:#ffffff;}</style><style id="kirki-inline-styles">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</style>
<style type="text/css" media="all">
.footnotes_reference_container {margin-top: 24px !important; margin-bottom: 0px !important;}
.footnote_container_prepare > p {border-bottom: 1px solid #aaaaaa !important;}
.footnote_tooltip { font-size: 13px !important; color: #494949 !important; background-color: #f7f7f7 !important; border-width: 1px !important; border-style: solid !important; border-color: #eeeeee !important; border-radius: 3px !important; -webkit-box-shadow: 2px 2px 11px #666666; -moz-box-shadow: 2px 2px 11px #666666; box-shadow: 2px 2px 11px #666666;}

.footnote_plugin_tooltip_text {
top: initial !important;
}
</style>
	</head>

	<body data-rsssl=1 class="post-template-default single single-post postid-25087 single-format-standard wp-custom-logo wp-embed-responsive depc_ page-has-comments has-sidebar">
				<link rel='stylesheet' id='fancybox-css'  href='https://fosspost.org/wp-content/themes/typer/assets/js/fancybox/jquery.fancybox.css?ver=1.9.7' type='text/css' media='all' />

		
		<div class="svq-page-wrapper">
			<a class="skip-link screen-reader-text" href="#primary">Skip to content</a>

			
<div id="header" class="svq-header-section svq-header--sticky theme-color-light svq-menu--center">
		<div class="navbar-container">
		<nav class="navbar navbar-expand-lg svq-content--large">
			<div class="ty-logo">
				<a href="https://fosspost.org/" class="custom-logo-link has-logo-dark has-logo-mobile has-logo-dark-mobile" rel="home"><img width="80" height="80" src="https://fosspost.org/wp-content/uploads/2020/07/cropped-fosspost.png" class="custom-logo svq-logo-default" alt="FOSS Post" loading="lazy" data-attachment-id="7259" data-permalink="https://fosspost.org/cropped-fosspost-png/" data-orig-file="https://fosspost.org/wp-content/uploads/2020/07/cropped-fosspost.png" data-orig-size="80,80" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cropped-fosspost.png" data-image-description="&lt;p&gt;https://fosspost.org/wp-content/uploads/2020/07/cropped-fosspost.png&lt;/p&gt;
" data-image-caption="" data-medium-file="https://fosspost.org/wp-content/uploads/2020/07/cropped-fosspost.png" data-large-file="https://fosspost.org/wp-content/uploads/2020/07/cropped-fosspost.png" /><img width="80" height="80" src="https://fosspost.org/wp-content/uploads/2020/07/cropped-fosspost-1.png" class="custom-logo svq-logo-dark" alt="FOSS Post" loading="lazy" data-attachment-id="7260" data-permalink="https://fosspost.org/cropped-fosspost-1-png/" data-orig-file="https://fosspost.org/wp-content/uploads/2020/07/cropped-fosspost-1.png" data-orig-size="80,80" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cropped-fosspost-1.png" data-image-description="&lt;p&gt;https://fosspost.org/wp-content/uploads/2020/07/cropped-fosspost-1.png&lt;/p&gt;
" data-image-caption="" data-medium-file="https://fosspost.org/wp-content/uploads/2020/07/cropped-fosspost-1.png" data-large-file="https://fosspost.org/wp-content/uploads/2020/07/cropped-fosspost-1.png" /><img width="80" height="80" src="https://fosspost.org/wp-content/uploads/2020/09/cropped-fosspost.png" class="custom-logo svq-mobile-logo" alt="FOSS Post" loading="lazy" data-attachment-id="18482" data-permalink="https://fosspost.org/cropped-fosspost-png-2/" data-orig-file="https://fosspost.org/wp-content/uploads/2020/09/cropped-fosspost.png" data-orig-size="80,80" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cropped-fosspost.png" data-image-description="&lt;p&gt;https://fosspost.org/wp-content/uploads/2020/09/cropped-fosspost.png&lt;/p&gt;
" data-image-caption="" data-medium-file="https://fosspost.org/wp-content/uploads/2020/09/cropped-fosspost.png" data-large-file="https://fosspost.org/wp-content/uploads/2020/09/cropped-fosspost.png" /><img width="80" height="80" src="https://fosspost.org/wp-content/uploads/2020/09/cropped-fosspost-1.png" class="custom-logo svq-mobile-logo-dark" alt="FOSS Post" loading="lazy" data-attachment-id="18486" data-permalink="https://fosspost.org/cropped-fosspost-1-png-2/" data-orig-file="https://fosspost.org/wp-content/uploads/2020/09/cropped-fosspost-1.png" data-orig-size="80,80" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cropped-fosspost-1.png" data-image-description="&lt;p&gt;https://fosspost.org/wp-content/uploads/2020/09/cropped-fosspost-1.png&lt;/p&gt;
" data-image-caption="" data-medium-file="https://fosspost.org/wp-content/uploads/2020/09/cropped-fosspost-1.png" data-large-file="https://fosspost.org/wp-content/uploads/2020/09/cropped-fosspost-1.png" /></a>			</div>

			<div class="navbar-custom-toggler collapsed" data-toggle="collapse" data-target="#typerMainMenu"
				 aria-controls="typerMainMenu" aria-expanded="false"
				 aria-label="Toggle navigation" role="button"
				 data-mobile-style="full-height">
				<span></span>
				<span></span>
				<span></span>
			</div>

			<div class="navbar-collapse collapse" id="typerMainMenu">
				<ul id="menu-categories-amp" class="navbar-nav mr-auto"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21234" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown dropdown-hover-animate menu-item-21234 nav-item"><a title="Browse Articles" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle   nav-link" id="menu-item-dropdown-21234">Browse Articles</a>
<ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-21234" role="menu">
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21257" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown dropdown-hover-animate menu-item-21257 nav-item"><a title="Open Source" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle   nav-link" id="menu-item-dropdown-21257">Open Source</a>
	<ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-21257" role="menu">
		<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21246" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21246 nav-item"><a title="Contributing to Open Source" href="https://fosspost.org/topics/contributing-to-open-source/" class="dropdown-item nav-link">Contributing to Open Source</a></li>
		<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21251" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21251 nav-item"><a title="Open Source Community" href="https://fosspost.org/topics/open-source-community/" class="dropdown-item nav-link">Open Source Community</a></li>
		<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21252" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21252 nav-item"><a title="Open Source For Designers" href="https://fosspost.org/topics/open-source-for-designers/" class="dropdown-item nav-link">Open Source For Designers</a></li>
		<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21253" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21253 nav-item"><a title="Open Source for Developers" href="https://fosspost.org/topics/open-source-for-developers/" class="dropdown-item nav-link">Open Source for Developers</a></li>
		<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21254" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21254 nav-item"><a title="Open Source for Engineers" href="https://fosspost.org/topics/open-source-for-engineers/" class="dropdown-item nav-link">Open Source for Engineers</a></li>
		<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21255" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21255 nav-item"><a title="Open Source for Enterprise" href="https://fosspost.org/topics/open-source-for-enterprise/" class="dropdown-item nav-link">Open Source for Enterprise</a></li>
	</ul>
</li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21237" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21237 nav-item"><a title="Analysis" href="https://fosspost.org/topics/analysis/" class="dropdown-item nav-link">Analysis</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21240" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21240 nav-item"><a title="Explanatory Articles" href="https://fosspost.org/topics/explanatory-articles/" class="dropdown-item nav-link">Explanatory Articles</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21241" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21241 nav-item"><a title="Linux Desktop Tips &amp; Tricks" href="https://fosspost.org/topics/linux-desktop-tips-tricks/" class="dropdown-item nav-link">Linux Desktop Tips &amp; Tricks</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21244" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21244 nav-item"><a title="Linux Distributions" href="https://fosspost.org/topics/linux-distributions/" class="dropdown-item nav-link">Linux Distributions</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21258" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown dropdown-hover-animate menu-item-21258 nav-item"><a title="Reviews" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle   nav-link" id="menu-item-dropdown-21258">Reviews</a>
	<ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-21258" role="menu">
		<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21235" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21235 nav-item"><a title="Distributions Reviews" href="https://fosspost.org/topics/distributions-reviews/" class="dropdown-item nav-link">Distributions Reviews</a></li>
		<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21243" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21243 nav-item"><a title="Programs Reviews" href="https://fosspost.org/topics/programs-reviews/" class="dropdown-item nav-link">Programs Reviews</a></li>
		<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21247" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21247 nav-item"><a title="Enterprise Software Reviews" href="https://fosspost.org/topics/enterprise-software-reviews/" class="dropdown-item nav-link">Enterprise Software Reviews</a></li>
	</ul>
</li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21238" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-has-children dropdown dropdown-hover-animate menu-item-21238 nav-item"><a title="Technical Tutorials" href="https://fosspost.org/topics/technical-tutorials/" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle   nav-link" id="menu-item-dropdown-21238">Technical Tutorials</a>
	<ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-21238" role="menu">
		<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21245" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21245 nav-item"><a title="Building Distributions" href="https://fosspost.org/topics/building-distributions/" class="dropdown-item nav-link">Building Distributions</a></li>
	</ul>
</li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21248" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21248 nav-item"><a title="Linux Command Line" href="https://fosspost.org/topics/linux-command-line/" class="dropdown-item nav-link">Linux Command Line</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21249" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21249 nav-item"><a title="Linux Gaming" href="https://fosspost.org/topics/linux-gaming/" class="dropdown-item nav-link">Linux Gaming</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21250" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21250 nav-item"><a title="Look &amp; Feel" href="https://fosspost.org/topics/look-feel/" class="dropdown-item nav-link">Look &amp; Feel</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21236" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21236 nav-item"><a title="News" href="https://fosspost.org/topics/news/" class="dropdown-item nav-link">News</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21256" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-21256 nav-item"><a title="Opinions" href="https://fosspost.org/topics/opinions/" class="dropdown-item nav-link">Opinions</a></li>
</ul>
</li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-14074" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown dropdown-hover-animate menu-item-14074 nav-item"><a title="Resources" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle   nav-link" id="menu-item-dropdown-14074">Resources</a>
<ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-14074" role="menu">
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-6869" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6869 nav-item"><a title="Full Linux Guide Series" href="https://fosspost.org/linux-full-guide/" class="dropdown-item nav-link">Full Linux Guide Series</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-20814" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20814 nav-item"><a title="Privacy &amp; Security Series" href="https://fosspost.org/privacy-security-series/" class="dropdown-item nav-link">Privacy &#038; Security Series</a></li>
</ul>
</li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-5003" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown dropdown-hover-animate menu-item-5003 nav-item"><a title="About FOSS Post" href="https://fosspost.org/about/" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle   nav-link" id="menu-item-dropdown-5003">About FOSS Post</a>
<ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-5003" role="menu">
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-5007" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5007 nav-item"><a title="Donate" href="https://fosspost.org/donate/" class="dropdown-item nav-link">Donate</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-5005" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5005 nav-item"><a title="Contact Us" href="https://fosspost.org/contact-us/" class="dropdown-item nav-link">Contact Us</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-5996" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5996 nav-item"><a title="Services" href="https://fosspost.org/services/" class="dropdown-item nav-link">Services</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-7098" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7098 nav-item"><a title="Request Article" href="https://forms.gle/R9ridDsmoEAsavNdA" class="dropdown-item nav-link">Request Article</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-5006" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-5006 nav-item"><a title="Privacy Policy" href="https://fosspost.org/privacy-policy/" class="dropdown-item nav-link">Privacy Policy</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21584" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21584 nav-item"><a title="Cookie Policy" href="https://fosspost.org/cookie-policy-us/" class="dropdown-item nav-link">Cookie Policy</a></li>
</ul>
</li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-14076" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14076 nav-item"><a title="Subscribe for $5" href="https://www.patreon.com/fosspost" class="nav-link">Subscribe for $5</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21479" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21479 nav-item"><a title="Take a Quiz" href="https://quiz.fosspost.org" class="nav-link">Take a Quiz</a></li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21482" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown dropdown-hover-animate menu-item-21482 nav-item"><a title="Social Media" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle   nav-link" id="menu-item-dropdown-21482">Social Media</a>
<ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-21482" role="menu">
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21483 nav-item"><a title="Facebook" href="https://facebook.com/fosspost" class="dropdown-item nav-link">Facebook</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21484" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21484 nav-item"><a title="Twitter" href="https://twitter.com/fosspost" class="dropdown-item nav-link">Twitter</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-21485" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21485 nav-item"><a title="Telegram" href="https://t.me/fosspost" class="dropdown-item nav-link">Telegram</a></li>
	<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-24445" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24445 nav-item"><a title="LinkedIn" href="https://www.linkedin.com/company/fosspost/" class="dropdown-item nav-link">LinkedIn</a></li>
</ul>
</li>
<li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-25063" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25063 nav-item"><a title="Subscriber Login" href="https://fosspost.org/wp-login.php?redirect_to=https%3A%2F%2Ffosspost.org%2F" class="nav-link">Subscriber Login</a></li>
</ul>
				
									<form class="form-inline pl-lg-7 my-2 my-lg-0" method="get" id="searchform"
						  action="https://fosspost.org/">
						<div class="ty-search">
							<a href="#" class="btn btn-link btn-search-toggle" data-action="btn-search-toggle">
							<span class="btn--default-state">
								<span class="svq-icon icon-search icon--x18"></span>							</span>
								<span class="btn--active-state">
								<span class="svq-icon icon-close icon--x18"></span>							</span>
							</a>
							<input class="form-control ty-search-input" type="text"
								   name="s"
								   value=""
								   placeholder="What do you want to find?"
								   aria-label="Search">
						</div>
					</form>
							</div>
		</nav>
	</div>
</div>



	<div class="svq-body-section svq-tpl-sr svq-content--large">


		<div class="svq-site-content">
			

	
<div class="svq-panel has-featured-image svq-panel--half svq-panel--dark svq-panel--off-height">
	
<figure class="svq-media-image svq--wide">
	<div class="svq-progressive">
		<div class="aspect-ratio-placeholder-fill aspect-ratio-1-1"></div>
		<div class="svq-progressive__placeholder-image svq-overlay svq-overlay--bottom">
			<img width="1600" height="1200" src="https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk.jpg" class="svq-progressive__image wp-post-image" alt="text" loading="lazy" data-object-fit="cover" srcset="https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk.jpg 1600w, https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk-1024x768.jpg 1024w, https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk-1440x1080.jpg 1440w, https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk-768x576.jpg 768w, https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk-1536x1152.jpg 1536w, https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk-45x34.jpg 45w" sizes="100vw" data-attachment-id="25098" data-permalink="https://fosspost.org/5-places-powered-by-linux-exist/photo-by-gabriel-heinzer/" data-orig-file="https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk.jpg" data-orig-size="1600,1200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Photo by Gabriel Heinzer" data-image-description="" data-image-caption="" data-medium-file="https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk-1024x768.jpg" data-large-file="https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk-1440x1080.jpg" title="Linux Everywhere 1">			<span class="svq-img-loader"></span>
			<noscript>
				<img width="1600" height="1200" src="https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk.jpg" class="skip-lazy wp-post-image" alt="text" loading="lazy" srcset="https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk.jpg 1600w, https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk-1024x768.jpg 1024w, https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk-1440x1080.jpg 1440w, https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk-768x576.jpg 768w, https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk-1536x1152.jpg 1536w, https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk-45x34.jpg 45w" sizes="100vw" data-attachment-id="25098" data-permalink="https://fosspost.org/5-places-powered-by-linux-exist/photo-by-gabriel-heinzer/" data-orig-file="https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk.jpg" data-orig-size="1600,1200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Photo by Gabriel Heinzer" data-image-description="" data-image-caption="" data-medium-file="https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk-1024x768.jpg" data-large-file="https://fosspost.org/wp-content/uploads/2021/11/4mw7nkqdbyk-1440x1080.jpg" title="Linux Everywhere 2">			</noscript>
		</div>
	</div>
	</figure>

	<header class="entry-header entry-header--large entry-header--h-center">
		<div class="entry-header-content ">
			
							<h1 class="entry-title">
											<span class="will-animate d-block" data-cssanimate="fadeIn">
							Linux is Everywhere: 5 Places Where You Didn&#8217;t Know It&#8217;s There						</span>
									</h1>
			
			
							
<div class="entry-meta will-animate"
     data-cssanimate="none">

			<div class="author-avatar">
			<a href="https://fosspost.org/author/fosspostteam/" rel="author">
				<img alt='FOSS Post Team' src='https://secure.gravatar.com/avatar/d5950c8ee5c1d31f65bb1daba6ab95df?s=60&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d5950c8ee5c1d31f65bb1daba6ab95df?s=120&#038;d=mm&#038;r=g 2x' class='avatar avatar-60 photo avatar-img' height='60' width='60' loading='lazy'/>			</a>
		</div>
	
	<div class="entry-meta__content">
					<span class="by-line">
	            <span class="author">
		             Written by <a href="https://fosspost.org/author/fosspostteam/" rel="author">FOSS Post Team</a>	            </span>
	        </span>
		
		<span class="posted-on">
							 <p class="post-modified-info" style="margin:0">Last Updated on November 28, 2021</p>						        </span>
	</div>

	</div>
					</div>
	</header>

	</div>

	
	<main id="primary" class="svq-main-page" >
		
	<article id="post-25087" class="svq-article post-25087 post type-post status-publish format-standard has-post-thumbnail hentry category-posts tag-news">
		<div class="entry-content-wrapper sticky-el-wrapper">
			
			
<div class="entry-content">
	<p>Have you every wondered where is <a href="https://fosspost.org/what-is-linux/">Linux</a>? What key sectors does it power and in what areas is it commonly used?</p>
<p>Many people, to this very day, think that Linux is nothing more than a <a href="https://fosspost.org/whats-the-best-linux-distribution/">server operating system</a> for advanced users, and nothing more. But that&#8217;s not true.</p>
<p>Linux can be found in unusual places that you may have not known before, and in today&#8217;s article we&#8217;ll be seeing some of these places.</p>
<div id="ez-toc-container" class="ez-toc-v2_0_17 counter-hierarchy counter-decimal ez-toc-light-blue">
<div class="ez-toc-title-container">
<p class="ez-toc-title">Table of Contents</p>
<span class="ez-toc-title-toggle"><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle" style="display: none;"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div>
<nav><ul class="ez-toc-list ez-toc-list-level-1"><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-1" href="#Unknown_Places_of_Linux_Existence" title="Unknown Places of Linux Existence">Unknown Places of Linux Existence</a><ul class="ez-toc-list-level-3"><li class="ez-toc-heading-level-3"><a class="ez-toc-link ez-toc-heading-2" href="#1_In_Your_Smartphone" title="1. In Your Smartphone">1. In Your Smartphone</a></li><li class="ez-toc-page-1 ez-toc-heading-level-3"><a class="ez-toc-link ez-toc-heading-3" href="#2_Serving_Most_Websites_You_Visit" title="2. Serving Most Websites You Visit">2. Serving Most Websites You Visit</a></li><li class="ez-toc-page-1 ez-toc-heading-level-3"><a class="ez-toc-link ez-toc-heading-4" href="#3_Serving_Your_Governments_Infrastructure" title="3. Serving Your Government&#8217;s Infrastructure">3. Serving Your Government&#8217;s Infrastructure</a></li><li class="ez-toc-page-1 ez-toc-heading-level-3"><a class="ez-toc-link ez-toc-heading-5" href="#4_In_The_Upcoming_Steam_Deck" title="4. In The Upcoming Steam Deck">4. In The Upcoming Steam Deck</a></li><li class="ez-toc-page-1 ez-toc-heading-level-3"><a class="ez-toc-link ez-toc-heading-6" href="#5_Powering_Global_Stock_Markets" title="5. Powering Global Stock Markets">5. Powering Global Stock Markets</a></li></ul></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-7" href="#Linux_is_Everywhere" title="Linux is Everywhere">Linux is Everywhere</a></li></ul></nav></div>
<h2><span class="ez-toc-section" id="Unknown_Places_of_Linux_Existence"></span>Unknown Places of Linux Existence<span class="ez-toc-section-end"></span></h2>
<h3><span class="ez-toc-section" id="1_In_Your_Smartphone"></span>1. In Your Smartphone<span class="ez-toc-section-end"></span></h3>
<p><img data-attachment-id="25094" data-permalink="https://fosspost.org/5-places-powered-by-linux-exist/photo-by-denny-muller/" data-orig-file="https://fosspost.org/wp-content/uploads/2021/11/hfwa-axq6ek.jpg" data-orig-size="1600,1067" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Photo by Denny Müller" data-image-description="" data-image-caption="" data-medium-file="https://fosspost.org/wp-content/uploads/2021/11/hfwa-axq6ek-1024x683.jpg" data-large-file="https://fosspost.org/wp-content/uploads/2021/11/hfwa-axq6ek.jpg" loading="lazy" class="alignnone size-medium wp-image-25094" src="https://fosspost.org/wp-content/uploads/2021/11/hfwa-axq6ek-1024x683.jpg" alt="Linux Everywhere 3" width="1024" height="683" srcset="https://fosspost.org/wp-content/uploads/2021/11/hfwa-axq6ek-1024x683.jpg 1024w, https://fosspost.org/wp-content/uploads/2021/11/hfwa-axq6ek-768x512.jpg 768w, https://fosspost.org/wp-content/uploads/2021/11/hfwa-axq6ek-1536x1024.jpg 1536w, https://fosspost.org/wp-content/uploads/2021/11/hfwa-axq6ek-1200x800.jpg 1200w, https://fosspost.org/wp-content/uploads/2021/11/hfwa-axq6ek-45x30.jpg 45w, https://fosspost.org/wp-content/uploads/2021/11/hfwa-axq6ek.jpg 1600w" sizes="(min-width: 960px) 75vw, 100vw" title="Linux Everywhere 4"></p>
<p>There is a very high chance that you are using an android-powered smartphone, but did you know android is a Linux distribution?</p>
<p>Yes, android is powered by the Linux kernel, and <a href="https://source.android.com" target="_blank" rel="noopener">many of android&#8217;s components are also open source</a>. It is true that not all of them are <a href="https://fosspost.org/what-is-open-source/">open source</a>, which is why you can&#8217;t say android is a fully open source OS, but still, it is powered by Linux nonetheless.</p>
<p>There are currently more than <a href="https://www.businessofapps.com/data/android-statistics/" target="_blank" rel="noopener">2.8 billion active android users</a>, which is 35% of the entire human race (7.9B). You can say that one third of the human race is using Linux on daily basis in their smartphones without even knowing about it!</p>
<h3><span class="ez-toc-section" id="2_Serving_Most_Websites_You_Visit"></span>2. Serving Most Websites You Visit<span class="ez-toc-section-end"></span></h3>
<p><img data-attachment-id="25095" data-permalink="https://fosspost.org/5-places-powered-by-linux-exist/photo-by-nasa/" data-orig-file="https://fosspost.org/wp-content/uploads/2021/11/q1p7bh3shj8.jpg" data-orig-size="1600,1065" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Photo by NASA" data-image-description="" data-image-caption="" data-medium-file="https://fosspost.org/wp-content/uploads/2021/11/q1p7bh3shj8-1024x682.jpg" data-large-file="https://fosspost.org/wp-content/uploads/2021/11/q1p7bh3shj8.jpg" loading="lazy" class="alignnone size-medium wp-image-25095" src="https://fosspost.org/wp-content/uploads/2021/11/q1p7bh3shj8-1024x682.jpg" alt="Linux Everywhere 5" width="1024" height="682" srcset="https://fosspost.org/wp-content/uploads/2021/11/q1p7bh3shj8-1024x682.jpg 1024w, https://fosspost.org/wp-content/uploads/2021/11/q1p7bh3shj8-768x511.jpg 768w, https://fosspost.org/wp-content/uploads/2021/11/q1p7bh3shj8-1536x1022.jpg 1536w, https://fosspost.org/wp-content/uploads/2021/11/q1p7bh3shj8-1200x800.jpg 1200w, https://fosspost.org/wp-content/uploads/2021/11/q1p7bh3shj8-45x30.jpg 45w, https://fosspost.org/wp-content/uploads/2021/11/q1p7bh3shj8.jpg 1600w" sizes="(min-width: 960px) 75vw, 100vw" title="Linux Everywhere 6"></p>
<p>You probably know that Linux is a very good operating system for servers, but do you know the actual number of websites that are served by Linux?</p>
<p>According to <a href="https://w3techs.com/technologies/overview/operating_system" target="_blank" rel="noopener">W3Techs</a>, Linux marketshare of Internet websites could be as high as 78.5% (It says Unix, but &lt;1% are actual Unix OSes), while Windows holds 21.7%.</p>
<p>Let alone that most of the top 500 companies in the US <a href="https://www.bitpipe.com/detail/RES/1403746183_920.html" target="_blank" rel="noopener">are depending</a> on enterprise Linux providers, such as <a href="https://fosspost.org/insights-on-redhat-suse-the-major-linux-companies/">Red Hat</a>, to power their infrastructure and serve their customers. Platforms such as Facebook, Google, Twitter, Youtube&#8230; They are all powered by Linux.</p>
<p>Thus, almost every Internet website you visit is powered by a Linux distribution that you don&#8217;t know about.</p>
<h3><span class="ez-toc-section" id="3_Serving_Your_Governments_Infrastructure"></span>3. Serving Your Government&#8217;s Infrastructure<span class="ez-toc-section-end"></span></h3>
<p><img data-attachment-id="25097" data-permalink="https://fosspost.org/5-places-powered-by-linux-exist/photo-by-aditya-joshi/" data-orig-file="https://fosspost.org/wp-content/uploads/2021/11/fohw4a1cr1q.jpg" data-orig-size="1600,820" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Photo by Aditya Joshi" data-image-description="" data-image-caption="" data-medium-file="https://fosspost.org/wp-content/uploads/2021/11/fohw4a1cr1q-1024x525.jpg" data-large-file="https://fosspost.org/wp-content/uploads/2021/11/fohw4a1cr1q.jpg" loading="lazy" class="alignnone size-medium wp-image-25097" src="https://fosspost.org/wp-content/uploads/2021/11/fohw4a1cr1q-1024x525.jpg" alt="Linux Everywhere 7" width="1024" height="525" srcset="https://fosspost.org/wp-content/uploads/2021/11/fohw4a1cr1q-1024x525.jpg 1024w, https://fosspost.org/wp-content/uploads/2021/11/fohw4a1cr1q-768x394.jpg 768w, https://fosspost.org/wp-content/uploads/2021/11/fohw4a1cr1q-1536x787.jpg 1536w, https://fosspost.org/wp-content/uploads/2021/11/fohw4a1cr1q-45x23.jpg 45w, https://fosspost.org/wp-content/uploads/2021/11/fohw4a1cr1q.jpg 1600w" sizes="(min-width: 960px) 75vw, 100vw" title="Linux Everywhere 8"></p>
<p>Linux was so good that even governments started picking it up many years ago. You will find many countries around that world that use Linux:</p>
<ul>
<li>Either as part of their technical infrastructure responsible of providing services to citizens.</li>
<li>Or as a default desktop OS on machines that belong to the state (E.g schools, universities, laboratories, hospitals&#8230; etc).</li>
</ul>
<p>Pretty much any government around the world is using Linux somewhere in its technical infrastructure. They have to do so, because using Microsoft Windows and buying a license for every machine they might have <a href="https://fosspost.org/governments-and-spending-on-software/">could be gigantically expensive</a> to the level that no government can afford it.</p>
<p><span style="font-size: revert; background-color: var(--body-bg-color); color: var(--text-color); font-family: var(--font-family); font-weight: var(--font-weight-normal);">U.S. Department of Defense for example <a href="https://linuxsecurity.com/features/linux-an-os-capable-of-effectively-meeting-the-us-government-s-security-needs-heading-into-2020" target="_blank" rel="noopener">uses Linux</a> to conduct its operations, Russia uses Linux on <a href="http://news.bbc.co.uk/2/hi/technology/7034828.stm" target="_blank" rel="noopener">all its school computers</a> and Brazil <a href="https://web.archive.org/web/20141015235133/https://www.userful.com/downloads/case-studies/userful-casestudy-brazil-2014.pdf" target="_blank" rel="noopener">does the same</a>. You will find Linux running pretty much in <a href="https://en.wikipedia.org/wiki/List_of_Linux_adopters" target="_blank" rel="noopener">most countries in the world</a>.</span></p>
<h3><span class="ez-toc-section" id="4_In_The_Upcoming_Steam_Deck"></span>4. In The Upcoming Steam Deck<span class="ez-toc-section-end"></span></h3>
<p><img data-attachment-id="25096" data-permalink="https://fosspost.org/5-places-powered-by-linux-exist/2021-11-28_09-18/" data-orig-file="https://fosspost.org/wp-content/uploads/2021/11/2021-11-28_09-18.png" data-orig-size="1162,644" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="2021-11-28_09-18" data-image-description="" data-image-caption="" data-medium-file="https://fosspost.org/wp-content/uploads/2021/11/2021-11-28_09-18-1024x568.png" data-large-file="https://fosspost.org/wp-content/uploads/2021/11/2021-11-28_09-18.png" loading="lazy" class="alignnone size-medium wp-image-25096" src="https://fosspost.org/wp-content/uploads/2021/11/2021-11-28_09-18-1024x568.png" alt="Linux Everywhere 9" width="1024" height="568" srcset="https://fosspost.org/wp-content/uploads/2021/11/2021-11-28_09-18-1024x568.png 1024w, https://fosspost.org/wp-content/uploads/2021/11/2021-11-28_09-18-768x426.png 768w, https://fosspost.org/wp-content/uploads/2021/11/2021-11-28_09-18-45x25.png 45w, https://fosspost.org/wp-content/uploads/2021/11/2021-11-28_09-18.png 1162w" sizes="(min-width: 960px) 75vw, 100vw" title="Linux Everywhere 10"></p>
<p>You may have heard about how Valve, the company behind <a href="https://fosspost.org/enable-steam-play-on-linux-to-run-windows-games/">Steam</a>, plans to release a handheld gaming computer called &#8220;<a href="https://store.steampowered.com/steamdeck/" target="_blank" rel="noopener">Steam Deck</a>&#8220;. But did you know that it is going to be powered by a Linux distribution as well?</p>
<p>Yes, because according to <a href="https://arstechnica.com/gaming/2021/08/valves-upcoming-steam-deck-will-be-based-on-arch-linux-not-debian/" target="_blank" rel="noopener">official Valve sources</a>, Steam Deck is going to use an Arch-based Linux distribution named SteamOS as a default operating system.</p>
<p>This means that if you are ever to buy one of these devices, then you&#8217;ll be gaming on a Linux platform!</p>
<h3><span class="ez-toc-section" id="5_Powering_Global_Stock_Markets"></span>5. Powering Global Stock Markets<span class="ez-toc-section-end"></span></h3>
<p>Stock markets need a reliable system capable of conducting many operations in real time with huge load. That&#8217;s why many stock markets around the world have switched to using Linux to conduct these operations.</p>
<p>Tokyo&#8217; Stock Exchange and NYSE Euronext are examples of stock markets that are fully <a href="https://www.redhat.com/en/blog/red-hat-enterprise-linux-powers-the-globes-stock-exchanges" target="_blank" rel="noopener">powered by Linux</a>. Thanks to enterprise Linux providers like Red Hat, stock markets can save money while still doing their normal financial activities.</p>
<p>These are not the only examples; <a href="https://www.pcworld.com/article/481872/how_linux_mastered_wall_street.html" target="_blank" rel="noopener">NASDAQ uses a Linux distribution</a> in its infrastructure as well, and the London Stock Exchange <a href="https://www.zdnet.com/article/the-london-stock-exchange-moves-to-novell-linux/" target="_blank" rel="noopener">has been running Linux</a> for more than a decade.</p>
<h2><span class="ez-toc-section" id="Linux_is_Everywhere"></span>Linux is Everywhere<span class="ez-toc-section-end"></span></h2>
<p>From your smartphone and the websites you visit all the way up to managing the economy of the country as well as its technical infrastructure, Linux has been a huge success in powering all of these sectors.</p>
<p>Perhaps the only sector where Linux is absent is the desktop, where it controls roughly <a href="https://gs.statcounter.com/os-market-share/desktop/worldwide" target="_blank" rel="noopener">2% only of the market</a>. Many Linux distributions and helpful tools exist for the Linux desktop, but hardware vendors have been historically very attracted to Microsoft&#8217;s money, which is why they don&#8217;t ship Linux by default.</p>


<p>See this video by Linux Foundation for how Linux is built:</p>



<figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe loading="lazy" title="How Linux is Built" width="720" height="405" src="https://www.youtube.com/embed/yVpbFMhOAwE?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</div></figure>

	<div class="svq-article-tags">
	    <span class="tags-category">
		<span class="tag-links"><a href="https://fosspost.org/topics/news/" rel="tag">News</a></span>	    </span>
	</div>

</div>
		</div>

		
<div class="entry-footer entry-footer--default">
	
	
	</div><!-- .entry-footer -->
	</article><!-- #post-25087 -->

	<!-- Start comment Template
	================================================== -->
	<style id="deeper-comments-custom-css">.dpr-influence-level-a:hover{color:#a02c2c}.dpr-influence-level-a:hover span{background-color:#a02c2c}.dpr-join-form-login-register a.dpr-discu-submit{box-shadow:0 3px 14px -4px #a02c2c}.dpr-discu-timeline-point{box-shadow:0 0 0 0 #a02c2c}.dpr-discu-timeline-point:hover{box-shadow:0 0 7px 0 #a02c2c}.dpr-discu-timeline-point{border-color:#a02c2c}.dpr-join-form-login-register a.dpr-discu-submit{background:#a02c2c;border-color:#ffffff}</style><style>.dpr-discu-container{width:100%}</style>

<!-- Primary Page Layout
	================================================== -->
	<div class="dpr-wrap">
		<div class='dpr-preloader-wrap'>
			<div class='dpr-preloader'></div>
		</div>
		<div class="dpr-container dpr-discu-container dpr-discu-container_25087 guest-allowed">
			<script type="text/javascript">
		jQuery(document).ready(function() {
			if(typeof jQuery(".dpr-discu-container_25087 .dpr-discu-wrap .dpr-discu-edit").depcEditComment == "undefined") {
				return;
			}
			jQuery(".dpr-discu-container_25087 .dpr-discu-wrap .dpr-discu-edit").depcEditComment({
				id: "25087",
				save: false
			});

			jQuery(".dpr-discu-container_25087 .dpr-discu-wrap .dpr-discu-edit .dpr_edit_comment").depcEditComment({
				id: "25087",
				save: true,
				nounce : "441fd24346"
			});

			jQuery(".dpr-discu-container_25087 .dpr-discu-wrap .dpr-discu-delete").depcEditComment({
				id: "25087",
				save: null,
				nounce : "441fd24346"
			});

			jQuery(".dpr-discu-container_25087 .dpr-discu-wrap .dpr-discu-flag").depcEditComment({
				id: "25087",
				save: -1,
				nounce : "441fd24346"
			});

			jQuery(".dpr-discu-container_25087 .dpr-discu-metadata-share-wrap .dpr-discu-sharing .dpr-discu-social-icon a").depcEditComment({
				id: "25087",
				save: -2,
				nounce : "441fd24346"
			});

		});

		</script>			<div class="dpr-join-form-wrap"><!-- deeper dpr-join-form-wrap /start -->
				<div class="dpr-join-form">
									<div class="dpr-join-form-area">
											<i class="sl-user"></i>
											<!-- <textarea readonly="" placeholder="Join the discussion..." class="">Join the discussion...</textarea> -->
						<button class="comment-toggle">Join the discussion</button>
					</div>
									<div class="dpr-submit-form-wrap" style="display: none;"><!-- deeper submit form wrapper /start -->
						<div class="dpr-submit-form-editor">
							<div id="dpr_container">
								<a id="dpr_call_panel" class="dpr_light dpr_right_bottom" data-emoji-panel="{'theme':'light', 'showOnMobile':false, 'close':false, 'position':'right_bottom'}" rel="nofollow noreferrer" title="Insertar Emoji"></a>

								<textarea class="dpr-add-editor" cols="45" rows="8" maxlength="65525" required="required" data-emoji-textarea></textarea>
							</div>
						</div>
						<div class="dpr-submit-form-fields">
							<span class="dpr-submit-form-fields-c dpr-submit-form-fieldswrap-name">
								<i class="sl-user"></i>
								<input class="dpr-submit-form-fields-c-name" require="required" type="text" name="name" placeholder="Name">
							</span>
							<span class="dpr-submit-form-fields-c dpr-submit-form-fieldswrap-email">
								<i class="sl-envelope-open"></i>
								<input class="dpr-submit-form-fields-c-email" require="required" type="email" name="email" placeholder="Email">
							</span>

							
						</div>
						
					</div><!-- deeper submit form wrapper /end -->
					<div class="dpr-join-form-inner">
						<div class="dpr-join-form-login-register">
							<script type="text/javascript">
		jQuery(document).ready(function() {

			jQuery(".dpr-discu-container_25087 .dpr-join-form-login-register .dpr-join-form-login-a").depcLoginForm({
				id: "25087",
				nounce: "99cd06fd07",
				register: false
			});

			jQuery(".dpr-discu-container_25087 .dpr-join-form-login-register .dpr-join-form-register-a").depcLoginForm({
				id: "25087",
				nounce: "99cd06fd07",
				register: true
			});

		});
		</script>														<a href="#" onclick="return false;"  class="dpr-discu-submit"><i class="sl-cursor"></i> Submit</a>
													</div>
						<div class="dpr-join-form-social-login">
													</div>

					</div>
				</div>

			</div>

				
	<div class="dpr-comments-count">
		0		Comment	</div>
						<div class="dpr-discu-main-loop-wrap">
					<h3>No Comment.</h3>

<script type="text/javascript">
	var dc_use_tinymce = 'on';
	var dc_use_emoji_tinymce = 'on';
	var dc_use_images = 'off';
</script>

<!-- End Comment loop Page layout
	================================================== -->
			</div>
		</div><!-- end dpr-container -->
	</div><!-- end dpr-wrap -->


<!-- End Document
	================================================== -->

<!-- End Start comment Template
	================================================== -->
	</main><!-- #primary -->




	
	<div class="svq-sidebar-page primary-sidebar" id="primary-sidebar">
		<div class="svq-sidebar-content widget-area svq-sticky-el"
			 data-stick-to="primary-sidebar" data-top="0">
			<section id="custom_html-10" class="widget_text widget widget_custom_html"><h3 class="widget-title"><span>Newsletter</span></h3><div class="textwidget custom-html-widget"><style type="text/css">
  @import url(https://static.mailerlite.com/assets/plugins/groot/modules/includes/groot_fonts/import.css?version=1628152);
</style>
<style type="text/css">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</style>
<div id="mlb2-2612657" class="ml-form-embedContainer ml-subscribe-form ml-subscribe-form-2612657">
  <div class="ml-form-align-center">
    <div class="ml-form-embedWrapper embedForm">
      <div class="ml-form-embedBody ml-form-embedBodyDefault row-form">
        <div class="ml-form-embedContent" style="">
          <h4>Monthly Newsletter</h4>
          <p>Get latest articles about open source, once per month.</p>
        </div>
        <form class="ml-block-form" action="https://static.mailerlite.com/webforms/submit/y7c9g3" data-code="y7c9g3" method="post" target="_blank">
          <div class="ml-form-formContent">
            <div class="ml-form-fieldRow ml-last-item">
              <div class="ml-field-group ml-field-email ml-validate-email ml-validate-required">
                <input aria-label="email" aria-required="true" type="email" class="form-control" data-inputmask="" name="fields[email]" placeholder="Email" autocomplete="email">
              </div>
            </div>
          </div>
          <input type="hidden" name="ml-submit" value="1">
          <div class="ml-form-embedSubmit">
            <button type="submit" class="primary">Stay Informed</button>
            <button disabled="disabled" style="display:none" type="button" class="loading"> <div class="ml-form-embedSubmitLoad"></div> <span class="sr-only">Loading...</span> </button>
          </div>
          <input type="hidden" name="anticsrf" value="true">
        </form>
      </div>
      <div class="ml-form-successBody row-success" style="display:none">
        <div class="ml-form-successContent">
          <h4>Thank you!</h4>
          <p>You have successfully joined our subscriber list.</p>
        </div>
      </div>
    </div>
  </div>
</div>
<script>
  function ml_webform_success_2612657(){var r=ml_jQuery||jQuery;r(".ml-subscribe-form-2612657 .row-success").show(),r(".ml-subscribe-form-2612657 .row-form").hide()}
</script>
<img src="https://track.mailerlite.com/webforms/o/2612657/y7c9g3?v1628288067" width="1" height="1" style="max-width:1px;max-height:1px;visibility:hidden;padding:0;margin:0;display:block" alt="." border="0">
<script src="https://static.mailerlite.com/js/w/webforms.min.js?v0c75f831c56857441820dcec3163967c" type="text/javascript"></script></div></section><section id="custom_html-11" class="widget_text extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget widget_custom_html"><h3 class="widget-title"><span>Ads</span></h3><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7543508590810245"
     crossorigin="anonymous"></script>
<!-- fosspost_2021_08_longsidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7543508590810245"
     data-ad-slot="3567129473"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section><section id="custom_html-9" class="widget_text widget widget_custom_html"><h3 class="widget-title"><span>Become a Supporter</span></h3><div class="textwidget custom-html-widget"><div class="patreonside">
<div class="patreonside-image">
<img src="https://quiz.fosspost.org/wp-content/uploads/2020/12/patreon-creators-patreon.png" width="128">
</div>
<div class="patreonside-text">
<p>For the price of one cup of coffee per month:</p>
<ul>
<li>Support the FOSS Post to produce more content.</li>
<li>Get a special account on our website.</li>
<li>Remove all the ads you are seeing (including this one!).</li>
<li>Help us get to our goal of 100 supporters, to start many initiatives.</li>
</ul></div>
<div class="patreonside-link">
<a href="https://patreon.com/fosspost" target="_blank" rel="noopener"><p></p>
<p>Become a Supporter</p>
<p></p></a></div><a href="https://patreon.com/fosspost" target="_blank" rel="noopener">
</a><p><a href="https://patreon.com/fosspost" target="_blank" rel="noopener"></a>
</p></div></div></section><section id="better_recent_comments-2" class="widget widget_recent_comments"><h3 class="widget-title"><span>Recent Comments</span></h3><ul id="better-recent-comments" class="recent-comments-list with-avatars"><li class="recentcomments recent-comment"><div class="comment-wrap" style="padding-left:50px; min-height:44px;"><span class="comment-avatar"><img alt='' src='https://secure.gravatar.com/avatar/f3339f9e9d3d99657fc8ccc0b97b5931?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f3339f9e9d3d99657fc8ccc0b97b5931?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' loading='lazy'/></span> <span class="comment-author-link">longshots</span> on <span class="comment-post"><a href="https://fosspost.org/linux-mint-vs-ubuntu/#comment-69065">Linux Mint vs Ubuntu In Less Than 10 Minutes</a></span>: &ldquo;<span class="comment-excerpt">You forgot to mention the screensaver &#8211; which is a dirty word in the linux world. I&#8217;m fully aware of&hellip;</span>&rdquo; <span class="comment-date">Nov 25, 22:53</span></div></li><li class="recentcomments recent-comment"><div class="comment-wrap" style="padding-left:50px; min-height:44px;"><span class="comment-avatar"><img alt='' src='https://secure.gravatar.com/avatar/34cae0f69d8b879490cf93959159b7d4?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/34cae0f69d8b879490cf93959159b7d4?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' loading='lazy'/></span> <span class="comment-author-link">pdaliu</span> on <span class="comment-post"><a href="https://fosspost.org/linux-mint-vs-ubuntu/#comment-69064">Linux Mint vs Ubuntu In Less Than 10 Minutes</a></span>: &ldquo;<span class="comment-excerpt">Timeshift is default in Linux Mint, which is a must-to-have app.&nbsp; That&#8217;s the major reason I love Linux Mint, though&hellip;</span>&rdquo; <span class="comment-date">Nov 25, 13:01</span></div></li><li class="recentcomments recent-comment"><div class="comment-wrap" style="padding-left:50px; min-height:44px;"><span class="comment-avatar"><img alt='' src='https://secure.gravatar.com/avatar/931d5f77af6cc35f5e34eb3498a1d0da?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/931d5f77af6cc35f5e34eb3498a1d0da?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' loading='lazy'/></span> <span class="comment-author-link">IGnatius T Foobar</span> on <span class="comment-post"><a href="https://fosspost.org/ubuntu-unity-remix-unity-desktop-future-updates/#comment-69061">5 Years Later, Unity Desktop Is Forming an Accidental Renaissance</a></span>: &ldquo;<span class="comment-excerpt">Unity was *awful* and it should have never existed.&nbsp; &nbsp;It made Ubuntu unusable.&nbsp; Killing it off and going back to&hellip;</span>&rdquo; <span class="comment-date">Nov 22, 02:10</span></div></li><li class="recentcomments recent-comment"><div class="comment-wrap" style="padding-left:50px; min-height:44px;"><span class="comment-avatar"><img alt='' src='https://secure.gravatar.com/avatar/53f747b7d7f3884e9559f75fb749b351?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/53f747b7d7f3884e9559f75fb749b351?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' loading='lazy'/></span> <span class="comment-author-link">M.Hanny Sabbagh</span> on <span class="comment-post"><a href="https://fosspost.org/ubuntu-unity-remix-unity-desktop-future-updates/#comment-69060">5 Years Later, Unity Desktop Is Forming an Accidental Renaissance</a></span>: &ldquo;<span class="comment-excerpt">It is dead, because that fork is for tablets and phones, not desktop Linux distributions.</span>&rdquo; <span class="comment-date">Nov 21, 18:16</span></div></li><li class="recentcomments recent-comment"><div class="comment-wrap" style="padding-left:50px; min-height:44px;"><span class="comment-avatar"><img alt='' src='https://secure.gravatar.com/avatar/337e0301210d8067e982f77a37187d01?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/337e0301210d8067e982f77a37187d01?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' loading='lazy'/></span> <span class="comment-author-link">Tony G</span> on <span class="comment-post"><a href="https://fosspost.org/ubuntu-unity-remix-unity-desktop-future-updates/#comment-69059">5 Years Later, Unity Desktop Is Forming an Accidental Renaissance</a></span>: &ldquo;<span class="comment-excerpt">Unity 8 isn&#8217;t dead. The UBPorts team are continuing work on it under the name Lomiri.</span>&rdquo; <span class="comment-date">Nov 21, 16:31</span></div></li><li class="recentcomments recent-comment"><div class="comment-wrap" style="padding-left:50px; min-height:44px;"><span class="comment-avatar"><img alt='' src='https://secure.gravatar.com/avatar/f7d24b2538d6c9728e5e5334302f8f75?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f7d24b2538d6c9728e5e5334302f8f75?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' loading='lazy'/></span> <span class="comment-author-link">Anonymous</span> on <span class="comment-post"><a href="https://fosspost.org/unsplash-wallpapers-desktop-app-software-opensource/#comment-69042">Unsplash Wallpapers is an Unsplash Desktop Open Source App</a></span>: &ldquo;<span class="comment-excerpt">You may also like this Firefox extension that loads fresh images from Unsplash with each new tab.https://addons.mozilla.org/en-GB/firefox/addon/deep-thought-tabs/ Written in pure&hellip;</span>&rdquo; <span class="comment-date">Nov 18, 13:20</span></div></li><li class="recentcomments recent-comment"><div class="comment-wrap" style="padding-left:50px; min-height:44px;"><span class="comment-avatar"><img alt='' src='https://secure.gravatar.com/avatar/53f747b7d7f3884e9559f75fb749b351?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/53f747b7d7f3884e9559f75fb749b351?s=80&#038;d=mm&#038;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' loading='lazy'/></span> <span class="comment-author-link">M.Hanny Sabbagh</span> on <span class="comment-post"><a href="https://fosspost.org/top-lightweight-linux-distributions/#comment-69041">5 Lightweight Linux Distributions to Revive Old Computers</a></span>: &ldquo;<span class="comment-excerpt">&#8220;Here, we are talking about hardware which is at most 10 years old.&#8221;</span>&rdquo; <span class="comment-date">Nov 14, 09:52</span></div></li></ul></section>		</div>
	</div><!-- #primary -->



		</div>
	</div>
	
<footer class="svq-footer-section section-reveal svq-footer-widgets">
	<div class="svq-content--large">
					
<div class="widget-area row" role="complementary" aria-label="Footer">
			<div class="col-lg-3 col-md-6 widget__column">
			<div id="meta-2" class="widget widget_meta"><h3 class="widget-title"><span>Meta Links</span></h3>
		<ul>
						<li><a rel="nofollow" href="https://fosspost.org/wp-login.php">Log in</a></li>
			<li><a href="https://fosspost.org/feed/">Entries feed</a></li>
			<li><a href="https://fosspost.org/comments/feed/">Comments feed</a></li>

			<li><a href="https://wordpress.org/">WordPress.org</a></li>
		</ul>

		</div>		</div>
	
			<div class="col-lg-3 col-md-6 widget__column">
			<div id="text-10" class="widget widget_text"><h3 class="widget-title"><span>Tools We Use</span></h3>			<div class="textwidget"><ul>
<li><strong><a href="https://m.do.co/c/25c615a3dc63" target="_blank" rel="noopener">DigitalOcean</a></strong> for a VPS hosting.</li>
<li><strong><a href="https://www.integromat.com/?pc=mhsabbagh" target="_blank" rel="noopener">Integromat</a></strong> for automating our social media channels.</li>
<li><strong><a href="https://wise.com/invite/u/m-hannys" target="_blank" rel="noopener">Wise</a></strong> for money transfers and payments.</li>
<li><strong><a href="https://amzn.to/3gxZsj6">Onyx Boox Note 3</a> </strong>for researching into topics we write about, and long reading.</li>
<li><a href="https://amzn.to/3yf5DhT" target="_blank" rel="noopener"><strong>Microsoft Designer Compact</strong></a> for a smooth writing experience, easily one of the best keyboards in the world.</li>
</ul>
</div>
		</div>		</div>
	
			<div class="col-lg-3 col-md-6 widget__column">
			<div id="search-3" class="widget widget_search"><h3 class="widget-title"><span>Search</span></h3><form role="search" method="get" class="search-form" action="https://fosspost.org/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div><div id="archives-3" class="widget widget_archive"><h3 class="widget-title"><span>Content Archives</span></h3>		<label class="screen-reader-text" for="archives-dropdown-3">Content Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://fosspost.org/2021/11/'> November 2021 &nbsp;(9)</option>
	<option value='https://fosspost.org/2021/10/'> October 2021 &nbsp;(3)</option>
	<option value='https://fosspost.org/2021/09/'> September 2021 &nbsp;(2)</option>
	<option value='https://fosspost.org/2021/08/'> August 2021 &nbsp;(2)</option>
	<option value='https://fosspost.org/2021/07/'> July 2021 &nbsp;(7)</option>
	<option value='https://fosspost.org/2021/06/'> June 2021 &nbsp;(2)</option>
	<option value='https://fosspost.org/2021/05/'> May 2021 &nbsp;(1)</option>
	<option value='https://fosspost.org/2021/04/'> April 2021 &nbsp;(1)</option>
	<option value='https://fosspost.org/2021/01/'> January 2021 &nbsp;(3)</option>
	<option value='https://fosspost.org/2020/12/'> December 2020 &nbsp;(5)</option>
	<option value='https://fosspost.org/2020/11/'> November 2020 &nbsp;(7)</option>
	<option value='https://fosspost.org/2020/10/'> October 2020 &nbsp;(5)</option>
	<option value='https://fosspost.org/2020/09/'> September 2020 &nbsp;(5)</option>
	<option value='https://fosspost.org/2020/08/'> August 2020 &nbsp;(11)</option>
	<option value='https://fosspost.org/2020/07/'> July 2020 &nbsp;(5)</option>
	<option value='https://fosspost.org/2020/06/'> June 2020 &nbsp;(5)</option>
	<option value='https://fosspost.org/2020/05/'> May 2020 &nbsp;(4)</option>
	<option value='https://fosspost.org/2020/04/'> April 2020 &nbsp;(3)</option>
	<option value='https://fosspost.org/2020/03/'> March 2020 &nbsp;(7)</option>
	<option value='https://fosspost.org/2020/02/'> February 2020 &nbsp;(3)</option>
	<option value='https://fosspost.org/2020/01/'> January 2020 &nbsp;(5)</option>
	<option value='https://fosspost.org/2019/12/'> December 2019 &nbsp;(6)</option>
	<option value='https://fosspost.org/2019/11/'> November 2019 &nbsp;(1)</option>
	<option value='https://fosspost.org/2019/10/'> October 2019 &nbsp;(2)</option>
	<option value='https://fosspost.org/2019/09/'> September 2019 &nbsp;(4)</option>
	<option value='https://fosspost.org/2019/08/'> August 2019 &nbsp;(3)</option>
	<option value='https://fosspost.org/2019/07/'> July 2019 &nbsp;(5)</option>
	<option value='https://fosspost.org/2019/06/'> June 2019 &nbsp;(3)</option>
	<option value='https://fosspost.org/2019/05/'> May 2019 &nbsp;(1)</option>
	<option value='https://fosspost.org/2019/04/'> April 2019 &nbsp;(1)</option>
	<option value='https://fosspost.org/2019/03/'> March 2019 &nbsp;(1)</option>
	<option value='https://fosspost.org/2019/02/'> February 2019 &nbsp;(4)</option>
	<option value='https://fosspost.org/2018/12/'> December 2018 &nbsp;(3)</option>
	<option value='https://fosspost.org/2018/11/'> November 2018 &nbsp;(1)</option>
	<option value='https://fosspost.org/2018/10/'> October 2018 &nbsp;(2)</option>
	<option value='https://fosspost.org/2018/09/'> September 2018 &nbsp;(1)</option>
	<option value='https://fosspost.org/2018/08/'> August 2018 &nbsp;(1)</option>
	<option value='https://fosspost.org/2018/07/'> July 2018 &nbsp;(2)</option>
	<option value='https://fosspost.org/2018/05/'> May 2018 &nbsp;(1)</option>
	<option value='https://fosspost.org/2018/04/'> April 2018 &nbsp;(3)</option>
	<option value='https://fosspost.org/2018/03/'> March 2018 &nbsp;(1)</option>
	<option value='https://fosspost.org/2018/02/'> February 2018 &nbsp;(1)</option>
	<option value='https://fosspost.org/2017/11/'> November 2017 &nbsp;(2)</option>
	<option value='https://fosspost.org/2017/10/'> October 2017 &nbsp;(1)</option>
	<option value='https://fosspost.org/2017/09/'> September 2017 &nbsp;(1)</option>
	<option value='https://fosspost.org/2017/08/'> August 2017 &nbsp;(2)</option>
	<option value='https://fosspost.org/2017/07/'> July 2017 &nbsp;(4)</option>
	<option value='https://fosspost.org/2017/06/'> June 2017 &nbsp;(5)</option>
	<option value='https://fosspost.org/2017/04/'> April 2017 &nbsp;(3)</option>
	<option value='https://fosspost.org/2017/03/'> March 2017 &nbsp;(2)</option>
	<option value='https://fosspost.org/2017/02/'> February 2017 &nbsp;(7)</option>
	<option value='https://fosspost.org/2017/01/'> January 2017 &nbsp;(3)</option>
	<option value='https://fosspost.org/2016/10/'> October 2016 &nbsp;(1)</option>
	<option value='https://fosspost.org/2016/09/'> September 2016 &nbsp;(3)</option>
	<option value='https://fosspost.org/2016/08/'> August 2016 &nbsp;(3)</option>
	<option value='https://fosspost.org/2016/07/'> July 2016 &nbsp;(7)</option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-3" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</div>		</div>
	
			<div class="col-lg-3 col-md-6 widget__column">
			<div id="text-11" class="widget widget_text"><h3 class="widget-title"><span>About Us</span></h3>			<div class="textwidget"><p>FOSS Post is an independent media outlet covering various topics and issues about free and open source software. With a team of professional writers and experienced staff from all over the world, we bring you the best quality open source journalism in the industry.</p>
</div>
		</div>		</div>
	</div>
		
		
	<div class="site-info">
		<p><img class="aligncenter wp-image-18480" src="https://fosspost.org/wp-content/uploads/2020/09/fosspost-240x240.png" alt="" width="123" height="123" /></p>
<p> </p>
<p>All rights reserved. Reproduction of any content on this website is not allowed without an authorized notice.</p>
<p> </p>
<p>Don't spam or be toxic/mean in comments, or you will be sent to <strong>/dev/null</strong>.</p>	</div>
	</div>
</footer>

</div><!-- .svq-page-wrapper -->

		<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/ui/core.min.js' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/jquery/ui/tooltip.min.js' id='jquery-ui-tooltip-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/dist/vendor/regenerator-runtime.min.js' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/dist/dom-ready.min.js' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/dist/hooks.min.js' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/dist/i18n.min.js' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/dist/a11y.min.js' id='wp-a11y-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/underscore.min.js' id='underscore-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/customize-base.min.js' id='customize-base-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/customize-preview.min.js' id='customize-preview-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/cookie-notice-and-consent-banner//js/cookiebanner.js?ver=1.7.2' id='cncb_banner-js'></script>
<script type='text/javascript' id='cncb_banner_init-js-extra'>
/* <![CDATA[ */
var cncb_plugin_object = {"theme":"CharadeJaffa","type":"confirm","bannerBlockType":"line","position":"bottom","corner":"rectangle","buttonType":"filled-rectangle","blind":{"visible":0},"message":{"html":"This website uses cookies to improve your browsing experience.","styles":[]},"link":{"html":"GDPR","href":"https:\/\/fosspost.org\/privacy-policy\/","styles":{"display":"inline"},"stylesHover":[]},"buttonDirection":"row","buttonAllow":{"html":"ALLOW","styles":{"border-style":"solid"},"stylesHover":{"border-style":"solid"}},"buttonDismiss":{"html":"OK","styles":{"border-style":"solid"},"stylesHover":{"border-style":"solid"}},"buttonDecline":{"html":"Not Allow","styles":{"border-style":"solid"},"stylesHover":{"border-style":"solid"}},"animationType":"slide-bottom","animationDelay":"0ms","animationDuration":"0.6ms","popupStyles":{"border-style":"none","margin-top":"auto","margin-right":"auto","margin-bottom":"auto","margin-left":"auto"},"accept":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/cookie-notice-and-consent-banner//js/cookiebanner-init.js?ver=1.7.2' id='cncb_banner_init-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/typer-pro/core/elements/assets/js/notes/sq-notes.js?ver=1.9.6' id='sq-notes-js'></script>
<script type='text/javascript' id='typer-pro-js-extra'>
/* <![CDATA[ */
var SqAjaxLoginLocale = {"loadingMessage":"Sending info, please wait..","errorOcurred":"Sorry, an error occurred","loginUrl":"https:\/\/fosspost.org\/wp-login.php","ajaxUrl":"https:\/\/fosspost.org\/wp-admin\/admin-ajax.php","agreeTerms":"You must agree with Privacy Policy"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/typer-pro/core/elements/assets/js/auth.js?ver=1.0.0' id='typer-pro-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/themes/typer/assets/js/modernizr-custom.js?ver=1.9.7' id='modernizr-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/themes/typer/assets/js/css-vars/css-vars-ponyfill.js?ver=1.9.7' id='css-vars-ponyfill-js'></script>
<script type='text/javascript' id='css-vars-ponyfill-js-after'>
jQuery(document).ready(function($) {cssVars();});
</script>
<script type='text/javascript' src='https://fosspost.org/wp-content/themes/typer/assets/js/jrespond.js?ver=1.9.7' id='jrespond-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/themes/typer/assets/js/popper/popper.js?ver=1.9.7' id='popper-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/themes/typer/assets/js/bootstrap.js?ver=1.9.7' id='bootstrap-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/themes/typer/assets/js/object-fit/objectFitPolyfill.basic.js?ver=1.9.7' id='objectfit-pollyfill-js'></script>
<script type='text/javascript' id='objectfit-pollyfill-js-after'>
jQuery(document).ready(function($) { objectFitPolyfill(); });
</script>
<script type='text/javascript' src='https://fosspost.org/wp-content/themes/typer/assets/js/intersection-observer.js?ver=1.9.7' id='intersection-polyfill-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/themes/typer/assets/js/index.js?ver=1.9.7' id='typer-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/easy-table-of-contents/vendor/js-cookie/js.cookie.min.js?ver=2.2.1' id='js-cookie-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/wp-review-pro/public/js/jquery.appear.js?ver=1.1' id='wp_review-jquery-appear-js'></script>
<script type='text/javascript' id='wp-util-js-extra'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/wp-util.min.js' id='wp-util-js'></script>
<script type='text/javascript' id='wp_review-js-js-extra'>
/* <![CDATA[ */
var wpreview = {"ajaxurl":"https:\/\/fosspost.org\/wp-admin\/admin-ajax.php","popup":{"enable":"0","width":"800px","animation_in":"bounceIn","animation_out":"bounceOut","overlay_color":"#0b0b0b","overlay_opacity":"0.8","post_type":"post","queryby":"category","orderby":"random","category":"0","tag":"0","review_type":"star","limit":"6","expiration":"30","cookie_name":"wpr-popup","delay":"0","show_on_load":false,"show_on_reach_bottom":false,"exit_intent":true,"screen_size_check":false,"screen_width":"0","embed_show_title":"","embed_show_thumbnail":"","embed_show_excerpt":"","embed_show_rating_box":"","embed_show_credit":""},"rateAllFeatures":"Please rate all features","verifiedPurchase":"(Verified purchase)","commentImageUploadNonce":"da0deb8ec4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/wp-review-pro/public/js/main.js?ver=3.4.6' id='wp_review-js-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/wp-review-pro/public/js/jquery.knob.min.js?ver=1.1' id='jquery-knob-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.8.2/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/quick-adsense-reloaded/assets/js/ads.js?ver=2.0.35' id='quads-admin-ads-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/themes/typer/assets/js/code-prettify/prettify.js?ver=1.9.7' id='code-prettify-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/themes/typer/assets/js/hc-sticky/hc-sticky-all.js?ver=1.9.7' id='hc-sticky-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/themes/typer/assets/js/fancybox/jquery.fancybox.js?ver=1.9.7' id='jquery-fancybox-js'></script>
<script type='text/javascript' id='jquery-fancybox-js-after'>
jQuery(document).ready(function($) { $('.svq-fancy-img').filter('[data-elementor-open-lightbox!="yes"]').fancybox(); });
</script>
<script type='text/javascript' src='https://fosspost.org/wp-content/themes/typer/assets/js/plyr/plyr.polyfilled.js?ver=1.9.7' id='plyr-polyfill-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/themes/typer/assets/js/plyr-init.js?ver=1.9.7' id='plyr-init-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/10.3/modules/theme-tools/responsive-videos/responsive-videos.min.js' id='jetpack-responsive-videos-min-script-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/fosspost.org\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/fosspost.org\/wp-admin\/admin-ajax.php","nonce":"ece530a479","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/fosspost.org\/wp-login.php?redirect_to=https%3A%2F%2Ffosspost.org%2F5-places-powered-by-linux-exist%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/10.3/_inc/build/carousel/jetpack-carousel.min.js' id='jetpack-carousel-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/easy-table-of-contents/vendor/smooth-scroll/jquery.smooth-scroll.min.js?ver=2.2.0' id='jquery-smooth-scroll-js'></script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/easy-table-of-contents/vendor/sticky-kit/jquery.sticky-kit.min.js?ver=1.9.2' id='jquery-sticky-kit-js'></script>
<script type='text/javascript' id='ez-toc-js-js-extra'>
/* <![CDATA[ */
var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"auto","scroll_offset":"30"};
/* ]]> */
</script>
<script type='text/javascript' src='https://fosspost.org/wp-content/plugins/easy-table-of-contents/assets/js/front.min.js?ver=2.0.17-1616796379' id='ez-toc-js-js'></script>
		<script>
			/(trident|msie)/i.test(navigator.userAgent) && document.getElementById && window.addEventListener &&
			window.addEventListener('hashchange', function() {
				var t, e = location.hash.substring(1);
				/^[A-z0-9_-]+$/.test(e) && (t = document.getElementById(e)) &&
				(/^(?:a|select|input|button|textarea)$/i.test(t.tagName) || (t.tabIndex = -1), t.focus());
			}, !1);
		</script>
		
	    <script type="text/javascript">
	        jQuery(document).ready(function ($) {
				var selector = $( 'ul li.meta-date' );
                if ( selector.length ) {
					selector.replaceWith( '<p class="post-modified-info">Last Updated on November 28, 2021 by <a href="" target="_blank" class="last-modified-author">M.Hanny Sabbagh</a></p>' );
				}
	        });
	    </script>
		<script src='https://stats.wp.com/e-202147.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.3',blog:'121649277',post:'25087',tz:'3',srv:'fosspost.org'} ]);
	_stq.push([ 'clickTrackerInit', '121649277', '25087' ]);
</script>

</body>
</html>
